Largest prime factor

7 篇文章 0 订阅
3 篇文章 0 订阅

Everybody knows any number can be combined by the prime number. 
Now, your task is telling me what position of the largest prime factor. 
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc. 
Specially, LPF(1) = 0. 

Input

Each line will contain one integer n(0 < n < 1000000). 

Output

Output the LPF(n). 

Sample Input

1
2
3
4
5

Sample Output

0
1
2
1
3

这是一个素数筛法,先打个素数表然后做就行了,本来想用一下线性筛法,结果写出来的样例过不去,只好改成这种普通筛法了,能过就行啊 哈哈。

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <vector>
#include <cmath>
#include <list>
#include <queue>
#include <stack>
#include <map> 
#include <set>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long ll;
const ll maxn=1000100;
ll isprimer[maxn];
int main()
{	 memset(isprimer,0,sizeof(isprimer));
	int cnt=1;
	for(int i=2;i<=maxn;i++)
	{
		if(isprimer[i]==0)
		{
			isprimer[i]=cnt;
			for(int j=1;j<=maxn&& i*j<=maxn;j++)
			{
				isprimer[i*j]=cnt;
			}
			cnt++;
		}	
	}
	ll n;
	while(~scanf("%d",&n))
	{
		printf("%lld\n",isprimer[n]);
	}
	return 0; 
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值