hdu 2054 A == B ?

A == B ?

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

 

Input

each test case contains two numbers A and B.

 

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

 

Sample Input

1 2

2 2

3 3

4 3

 

Sample Output

NO

YES

YES

NO

 

问题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2054

问题分析:

  • 不必想太多,不用考虑前导0的问题
  • 找到小数点,将小数点后的无用的0去掉即可。

源代码

#include <iostream>
#include <cstdio>
#include <string>
#include <algorithm>
#include <vector>
#include <set>
#include <map>
#include <iterator>
#include <cstring>
#include <cctype>
#include <stack>
using namespace std;
char s1[50000], s2[50000];

void f(char s[])            //简化字符串
{
    int len = strlen(s);    
    int tag = 0;
    for(int i = 0; i < len; i++)    //找是否有小数点
    {
        if(s[i] == '.')
        {
            tag = 1;
            break;
        }
    }
    if(tag)    //有小数点
    {
        for(int i = len-1; i >= 0; i--)
        {
            if(s[i] == '0')        //将无用的'0'换为'\0'
                s[i] = '\0';
            else
                break;
            len--;
        }
        if(s[len-1] == '.')    //如果小数点后的0全是无用的,则将小数点换为'\0'
            s[len-1] = '\0';

    }
}

int main()
{
    while(scanf("%s%s", s1, s2) != EOF)
    {
        f(s1);
        //printf("%s\n", s1);
        f(s2);
        //printf("%s\n", s2);
        if(strcmp(s1, s2))    //比较s1和s2是否相等
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值