"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.
Output Specification:
First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.
Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888
#include <cstdio>
#include <cstring>
#include<iostream>
#include <vector>
#include<math.h>
#include<string>
#include <algorithm>
#include<set>
using namespace std;
const int maxn= 100010; //最大顶点数
set<int> st;
int main(){
int n,couple[maxn]={0},m;bool exsit[maxn]={0}; //不出内存超限不换容器,容器是后备;
cin>>n;
for(int i=0;i<n;i++){
int c1,c2;
cin>>c1>>c2;
couple[c1]=c2;couple[c2]=c1;
}cin>>m;int c3[maxn];
for(int i=0;i<m;i++){
cin>>c3[i];
exsit[c3[i]]=1;
}
for(int i=0;i<m;i++){
if(!exsit[couple[c3[i]]])
st.insert(c3[i]);
}
cout<<st.size()<<endl;
for(set<int>::iterator it=st.begin();it!=st.end();it++){
if(it!=st.begin()) cout<<" ";
printf("%05d",*it); //坑,不提示段错误;
}
}