题目地址

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:
For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

#include <cstdio>
#include <cstring>
#include<iostream>
#include <vector>
#include<math.h>
#include<string>
#include<queue>
#include <algorithm>
#include<set>
#include<map>
using namespace std;
const int maxn=1010;
int n,m,q,k;bool G[maxn][maxn]={0};
int main(){
    cin>>n>>m;int v1,v2;
    for(int i=0;i<m;i++){
        cin>>v1>>v2;
        G[v1][v2]=G[v2][v1]=1;
    }
    cin>>q;
    while(q--){
        cin>>k;int a[maxn];bool book[maxn]={0},is_clique=1,is_max=1;        //不初始0每次循环值不变;
        for(int i=0;i<k;i++){
            cin>>a[i];book[a[i]]=1;
            if(!is_clique) continue;
            for(int j=0;j<i;j++) if(!G[a[i]][a[j]]) is_clique=0;
        }
        if(!is_clique){
            cout<<"Not a Clique"<<endl;continue;
        }
        for(int i=1;i<=n;i++){
            if(book[i]) continue;       //根本没走到5;
            int cnt=0;
            for(int j=0;j<k;j++){
                if(G[i][a[j]]) cnt++;
            }
            if(cnt==k){             //有外点和内点连通;
                is_max=0;
//                cout<<cnt<<endl;
                break;
            }
        }
        if(is_max) printf("Yes\n");
        else printf("Not Maximal\n");
    }
}