【 状压dp 】POJ 3254

Farmer John has purchased a lush new rectangular pasture composed of M byN (1 ≤M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)
Output
Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.
Sample Input
2 3
1 1 1
0 1 0
Sample Output
9
Hint
Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

题意:有一个n*m的菜地,0表示不能种植,1表示能种植,现在要求在菜地上种粮食,并且粮食上下左右不能相邻,问有多少种种植方法。

思路: n和m较小,并且只有0和1两种状态,用状压。剩下的代码有注释。
#include<stdio.h>
#include<string.h> 
#include<algorithm>
using namespace std;
const int mod = 1e8;
const int MAX = 1 << 13;
int vis[MAX],maps[MAX],dp[13][MAX];//maps存的是实际的图,vis存的是可行图 

bool judge_place(int x)
{
	return x & (x<<1);//判断是否有左右相邻的 1 ,有相邻1返回1 ,没有返回0 
}

bool judge_line(int i, int j)
{
	return maps[i] & vis[j];/*实际图和可行图是否有重合的1,就是说实际图不能放东西,
							但是可行图这个位置有东西。返回1说明有重合1.也就是不符合要求。 */ 
} 

int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		for(int i = 1; i <= n; i++)
			for(int j = 1,x; j <= m; j++){
				scanf("%d",&x);
				if(x == 0) maps[i] += (1 << (j-1));//如果实际图是0代表不能放东西,为了方便比较与代码实现,将1表示为不能放东西 
			}
		int count = 0;
		int ans = 0;
		for(int i = 0; i < (1<<m); i++) 	
			if(!judge_place(i))//注意取! 0代表状态可行 
				vis[count++] = i;//可行的行的状态 
		for(int i = 0; i < count; i++)
			if(!judge_line(1,i))//注意取! 0代表状态可行 
				dp[1][i] = 1;// 初始化第一行的状态 
		for(int i = 2; i <= n; i++)
		{
			for(int j = 0; j < count; j++)
				if(!judge_line(i,j))//判断状态是否可行
					for(int k = 0; k < count; k++){
						if(!(vis[j] & vis[k]))//判断上下相邻的状态 
							dp[i][j] += dp[i-1][k];// 如果没有上下相邻,下一行加上 
					}
				 
		 } 
		 for(int i = 0; i < count; i++)
		 	ans = (ans + dp[n][i]) % mod;
		printf("%d\n",ans);
	}
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值