【POJ】Apple Catching-2385 (经典DP)

题目链接:点击查看

Apple Catching

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 14388Accepted: 7052

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.


Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).


Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W


* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2 
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS:


Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.


OUTPUT DETAILS:


Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

一道很经典的DP问题,状态转移方程: DP[i][j] = max(DP[i-1][j],DP[i-1][j-1]),记得DP[i][j]++

AC代码:
#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<string.h>
using namespace std;

int a[2000];
int dp[2000][35];       //定义dp数组,一维为时刻,二维为移动次数。
int main(){
    int t,w;
    scanf("%d %d",&t,&w);
    for(int i=1;i<=t;i++)
        scanf("%d",&a[i]);
    memset(dp,0,sizeof(dp));            //初始化
    if(a[1]==1){                        //第一个苹果可以接住
        dp[1][0] = 1;
        dp[1][1] = 0;
    }
    else{                               //接不着
        dp[1][1] = 1;
        dp[1][0] = 0;
    }
    for(int i=2;i<=t;i++){
        for(int j=0;j<=w;j++){
            if(j==0){           //初始化
                dp[i][j] = dp[i-1][j];
            }
            else{
                dp[i][j] = max(dp[i-1][j],dp[i-1][j-1]);
            }
            if(j%2 + 1 == a[i])
                dp[i][j]++;
        }
    }
    int ans = 0;
    for(int i=0;i<=w;i++){
        if(dp[t][i] > ans)
            ans = dp[t][i]; 
    }
    printf("%d\n",ans);
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值