hdu 简单DP 1010 Beans

Beans

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 42   Accepted Submission(s) : 20
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?

Input

There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

Output

For each case, you just output the MAX qualities you can eat and then get.

Sample Input

4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6

Sample Output

242

Source

2009 Multi-University Training Contest 4 - Host by HDU

//给你一个n*m的矩阵,拿了其中的一个数就不能拿左右两个的和上下两行
//问你怎么拿得到的数最大
//两个dp,状态转移方程dp[i]=max(dp[i-1],dp[i-2]+a[i])
//要么拿前一行范围内的最大值但不拿自己,要么拿前面两行范围内的最大再加上自己
#include <bits/stdc++.h>
using namespace std;
int a[200005],b[200005],dp[200005];
int n,m,p;
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                int x;
                scanf("%d",&x);  //不保存n*m的矩阵,一边输入一边判断,用cin就超时啦
                if(j==1)
                {
                    a[j]=max(0,x);
                    continue;
                }
                else if(j==2)
                {
                    a[j]=max(a[j-1],x);
                }
                a[j]=max(a[j-1],a[j-2]+x);   //判断这一行能取得的最大值
            }
            b[i+1]=a[m];
        }
        int ans=-1;
        b[0]=b[1]=0;
        for(int i=2; i<=n+1; i++)
        {
            dp[i]=max(dp[i-1],dp[i-2]+b[i]);  //判断怎么选择行可以取得最大值
            ans=max(ans,dp[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值