hdu 简单DP 1011 Largest Submatrix

Largest Submatrix

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 39   Accepted Submission(s) : 16
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Now here is a matrix with letter 'a','b','c','w','x','y','z' and you can change 'w' to 'a' or 'b', change 'x' to 'b' or 'c', change 'y' to 'a' or 'c', and change 'z' to 'a', 'b' or 'c'. After you changed it, what's the largest submatrix with the same letters you can make?

Input

The input contains multiple test cases. Each test case begins with m and n (1 ≤ m, n ≤ 1000) on line. Then come the elements of a matrix in row-major order on m lines each with n letters. The input ends once EOF is met.

Output

For each test case, output one line containing the number of elements of the largest submatrix of all same letters.

Sample Input

2 4
abcw
wxyz

Sample Output

3

Source

2009 Multi-University Training Contest 7 - Host by FZU

//枚举三种状态,变成类似于木棍求面积的问题,用了o(n^3)的方法,也可以用单调栈o(n^2)
#include <bits/stdc++.h>
using namespace std;
int n,m,ans;
char a[1005][1005];
int h[1005][1005],l[1005],r[1005];
void DP()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            l[j]=r[j]=j;//初始化左右边
        }
        h[i][0]=h[i][m+1]=-1;
        for(int j=1;j<=m;j++)
        {
            while(h[i][l[j]-1]>=h[i][j]) //当左边的比自己的高,更新l
                l[j]=l[l[j]-1];
        }
        for(int j=m;j>=1;j--)
        {
            while(h[i][r[j]+1]>=h[i][j]) //当右边的比自己高,更新r
                r[j]=r[r[j]+1];
        }
        for(int j=1;j<=m;j++)
            ans=max(ans,(r[j]-l[j]+1)*h[i][j]); //宽度*高度为面积,更新、ans
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ans=-1;
        for(int i=1;i<=n;i++)
        {
            scanf("%s",a[i]+1);
        }
        memset(h,0,sizeof(h));
        for(int i=1;i<=n;i++) //枚举全为a
        {
            for(int j=1;j<=m;j++)
            {
                char q=a[i][j];
                if(q=='a'||q=='w'||q=='y'||q=='z')
                {
                    h[i][j]=h[i-1][j]+1;//得到每一个数,列上字母最大的相同数
                }
            }
        }
        DP();
        memset(h,0,sizeof(h));
        for(int i=1;i<=n;i++) //枚举全为b
        {
            for(int j=1;j<=m;j++)
            {
                char q=a[i][j];
                if(q=='b'||q=='w'||q=='x'||q=='z')
                {
                    h[i][j]=h[i-1][j]+1;
                }
            }
        }
        DP();
        memset(h,0,sizeof(h));
        for(int i=1;i<=n;i++)  //枚举全为c
        {
            for(int j=1;j<=m;j++)
            {
                char q=a[i][j];
                if(q=='c'||q=='x'||q=='y'||q=='z')
                {
                    h[i][j]=h[i-1][j]+1;
                }
            }
        }
        DP();
        printf("%d\n",ans);
    }
    return 0;
}













  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值