【SPFA判负环】[kuangbin带你飞]专题四 最短路练习 F - Wormholes

 

F - Wormholes

 POJ - 3259 

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler backT seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

//此题应为SPFA判是否有负环,因为如果可以得到负环,就代表可回到时间按之前
//给你n个农场,m条边,w个虫洞,m为双向边,w为单向边,问能不能从初始点走回来回到时间之前
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int maxn=6000;
const int inf=1e6+10;
int vis[maxn],head[maxn],end[maxn],next[maxn];
int cnt[maxn],cost[maxn],pay[maxn],e,flag,n,m,w;

void init()
{
    e=0,flag=0;
    memset(vis,0,sizeof(vis));    //是否标记过
    memset(head,-1,sizeof(head)); //u为起点的最后一条边,出事之前没有边,为-1
    memset(pay,inf,sizeof(pay));  //到达每个农场最少的花费,初始为inf
    memset(cnt,0,sizeof(cnt));    //每个点放入队列几次
}

void add(int u,int v,int w)
{
    end[e]=v;
    cost[e]=w;
    next[e]=head[u];    //第e条边的上一条边
    head[u]=e++;
}

int SPFA()
{
    queue <int> q;
    q.push(1);
    pay[1]=0;     //起始点花费为0元
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=head[u];i!=-1;i=next[i])
        {
            int v=end[i];
            int w=cost[i];
            if(pay[v]>pay[u]+w)  //要是终点的钱>起点+路径花费,就更新
            {
                pay[v]=pay[u]+w;
                if(!vis[v])
                {
                    vis[v]=1;
                    q.push(v);
                    ++cnt[v];
                    if(cnt[v]>n) return 1;
                }
            }
        }
    }
    return -1;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        scanf("%d%d%d",&n,&m,&w);
        for(int i=1;i<=m;i++)
        {
            int u,v,c;
            scanf("%d%d%d",&u,&v,&c);
            add(u,v,c);
            add(v,u,c);
        }
        for(int i=1;i<=w;i++)
        {
            int u,v,c;
            scanf("%d%d%d",&u,&v,&c);
            add(u,v,-c);
        }
        flag=SPFA();
        if(flag==1) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值