【二进制优化+DP多重背包求和】ACM-ICPC 2018 焦作赛区网络预赛 K. Transport Ship

 K. Transport Ship

  •  65536K

There are NN different kinds of transport ships on the port. The i^{th}ith kind of ship can carry the weight of V[i]V[i] and the number of the i^{th}ith kind of ship is 2^{C[i]} - 12C[i]−1. How many different schemes there are if you want to use these ships to transport cargo with a total weight of SS?

It is required that each ship must be full-filled. Two schemes are considered to be the same if they use the same kinds of ships and the same number for each kind.

Input

The first line contains an integer T(1≤T≤20), which is the number of test cases.

For each test case:

The first line contains two integers: N(1≤N≤20),Q(1≤Q≤10000), representing the number of kinds of ships and the number of queries.

For the next NN lines, each line contains two integers: V[i](1≤V[i]≤20),C[i](1≤C[i]≤20), representing the weight the i^{th}ith kind of ship can carry, and the number of the i^{th}ith kind of ship is 2^C[i]−1.

For the next Q lines, each line contains a single integer: S(1≤S≤10000), representing the queried weight.

Output

For each query, output one line containing a single integer which represents the number of schemes for arranging ships. Since the answer may be very large, output the answer modulo 1000000007.

样例输入

1
1 2
2 1
1
2

样例输出

0
1

给你n种船

每种船的容积为想,数量为2^y-1

询问容积为v的货物,放入这些船中(要求放入的船要能放满)

请问有多少种方案数

#include <bits/stdc++.h>
using namespace std;
const int mod=1e9+7;
int dp[405][10005];  //二进制优化,dp[i][j]:用了前i种船能够达到j的容积的方案数
int v[405];  //将每种船 容量为x,数量为(2^y-1)艘,变成二进制下的数量,可以将所有船的容积凑成400种,每种船最多20种
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m,cnt=0,x,y;
        scanf("%d%d",&n,&m);
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            y=(1<<y)-1;
            for(int i=1;i<=y;i*=2)
            {
                v[++cnt]=i*x;   
            }
        }
        for(int i=1;i<=cnt;i++)
        {
            for(int j=0;j<=10000;j++)
            {
                dp[i][j]=dp[i-1][j];
                if(j>=v[i]) dp[i][j]=(dp[i][j]+dp[i-1][j-v[i]])%mod;
            }
        }
        while(m--)
        {
            scanf("%d",&x);
            printf("%d\n",dp[cnt][x]);
        }
    }
    return 0;
}
#include <bits/stdc++.h>
using namespace std;
const int mod=1e9+7;
int dp[10005];
int v[25],c[25];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m,x;
        scanf("%d%d",&n,&m);
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&v[i],&c[i]);
            for(int j=1;j<=(1<<c[i])-1;j<<=1)
            {
                for(int k=10000;k>=j*v[i];k--)
                {
                    dp[k]=(dp[k]+dp[k-j*v[i]])%mod;
                }
            }
        }
        while(m--)
        {
            scanf("%d",&x);
            printf("%d\n",dp[x]);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值