【DP+状态压缩】HDU - 5119 H - Happy Matt Friends

H - Happy Matt Friends HDU - 5119

Matt has N friends. They are playing a game together. 

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins. 

Matt wants to know the number of ways to win.

Input

The first line contains only one integer T , which indicates the number of test cases. 

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 10 6). 

In the second line, there are N integers ki (0 ≤ k i ≤ 10 6), indicating the i-th friend’s magic number.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.

Sample Input

2
3 2
1 2 3
3 3
1 2 3

Sample Output

Case #1: 4
Case #2: 2

Hint

In the first sample, Matt can win by selecting:
friend with number 1 and friend with number 2. The xor sum is 3.
friend with number 1 and friend with number 3. The xor sum is 2.
friend with number 2. The xor sum is 2.
friend with number 3. The xor sum is 3. Hence, the answer is 4.

给你40个数,每个数<10^6,问你有多少种取法可以使异或和>=m

有一个bug:题目虽然告诉你数<10^6,也就是2^17,理论上来说异或和不会到2^18

但是你开到2^18就错了,还是开到20,其实19也行

dp[i][j]=前i个数异或和为j的方法有几个

dp[i][j]+=dp[i-1][j];//第i个数不拿
dp[i][j^val[i]]+=dp[i-1][j];//第i个数拿了

!看到40 ,看到10^6,应该有状态压缩的感觉,可惜当时没想到

#include <bits/stdc++.h>
#define ll long long
using namespace std;
const int maxn=(1<<20)+5;
ll dp[45][maxn],val[45];
int main()
{
    int T,cas=0;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) scanf("%d",&val[i]);
        memset(dp,0,sizeof(dp));
        dp[1][0]=dp[1][val[1]]=1;
        for(int i=2;i<=n;i++)
        {
            for(int j=0;j<=(1<<20);j++)
            {
                dp[i][j]+=dp[i-1][j];//第i个数不拿
                dp[i][j^val[i]]+=dp[i-1][j];//第i个数拿了
            }
        }
        ll sum=0;
        for(int i=m;i<=(1<<20);i++)
        {
            sum+=dp[n][i];
        }
        printf("Case #%d: %lld\n",++cas,sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值