【完全背包】HDU - 5534 H - Partial Tree

5 篇文章 0 订阅

H - Partial Tree  HDU - 5534 

In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree. 

You find a partial tree on the way home. This tree has nn nodes but lacks of n−1 edges. You want to complete this tree by adding n−1 edges. There must be exactly one path between any two nodes after adding. As you know, there are many ways to complete this tree, and you want to make the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is f(d), where f is a predefined function and d is the degree of this node. What's the maximum coolness of the completed tree?

Input

The first line contains an integer T indicating the total number of test cases. 
Each test case starts with an integer n in one line, 
then one line with n−1 integers f(1),f(2),…,f(n−1)
1≤T≤2015 
2≤n≤2015 
0≤f(i)≤10000 
There are at most 10 test cases with n>100.

Output

For each test case, please output the maximum coolness of the completed tree in one line.

Sample Input

2
3
2 1
4
5 1 4

Sample Output

5
19
给你n个点,让你连n-1条边
告诉你如果该节点是的度数是1-(n-1),那么该节点的权值为f[i]
输出最大权值之和
因为n个点连成树,那么总度数为2*n-2
又因为一定每个点的度数>=1,所以直接变成剩下的n-2度怎么分配
转化成了dp


#include <bits/stdc++.h>
using namespace std;
const int inf=0x3f3f3f3f;
int f[2020],dp[2020];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(dp,-inf,sizeof(dp));
        int n;
        scanf("%d",&n);
        for(int i=1;i<n;i++) scanf("%d",&f[i]);
        dp[0]=f[1]*n;//因为不管怎么连,初始度数其实为n,每个点都连到,所以初始dp[0]=f[1]*n
        for(int i=2;i<n;i++) f[i]=f[i]-f[1];//因为已经加过了度1的值,所以之后所有值在dp时是加的,就要改成f[i]-f[1];
        f[1]=0;
        for(int i=1;i<=n-2;i++)
        {
            for(int j=0;j<=n-2;j++)
            {
                if(j-i>=0)
                {
                    dp[j]=max(dp[j],dp[j-i]+f[i+1]);//目前总度数为n+j时所能达到的最大答案
                    //如果有一个节点要变的话,就是原先度数-要变的度数的值(dp[j-i])+改变后的节点的权值(f[i+1])
                    //之所以是f[i+1]因为本来初始度数就为1
                }
            }
        }
        printf("%d\n",dp[n-2]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值