【凸包+旋转卡壳(最远点对)】POJ - 2187 A - Beauty Contest

A - Beauty Contest POJ - 2187 

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 
 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input

4
0 0
0 1
1 1
1 0

Sample Output

2

Hint

Farm 1 (0, 0) and farm 3 (1, 1) have the longest distance (square root of 2) 

给你n个点,求最远两点的距离

因为n有50000,所以直接暴力轮肯定会超时的

用凸包的graham方法,得到最大凸多边形,那么一定是在凸多边形上的一对点是最远点

接下来用旋转卡壳的方法

因为凸包上的点依次与对应边产生的距离成单峰函数

所以,逆时针枚举边时,最远点的变化也是逆时针的

最远点对必然属于对蹱点集合

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=50005;
struct point
{
    int x,y;
}pt[maxn],ans[maxn];
int cross(point a,point b,point c)
{
    return (b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x);
}
int dist(point s,point e)
{
    return (s.x-e.x)*(s.x-e.x)+(s.y-e.y)*(s.y-e.y);
}
int cmp(point a,point b)  //极角排序
{
    if(cross(pt[0],a,b)>0) return 1;
    if(cross(pt[0],b,a)==0&&dist(pt[0],b)>dist(pt[0],a)) return 1;
    return 0;
}
int graham(int n)
{
    int top=2;
    sort(pt+1,pt+n,cmp);
    ans[0]=pt[0],ans[1]=pt[1],ans[2]=pt[2];
    for(int i=3;i<n;i++)
    {
        while(top>=1&&cross(ans[top-1],ans[top],pt[i])<=0) top--;
        ans[++top]=pt[i];
    }
    return top;
}

int qiake(int top)
{
    int q=1,res=0;
    ans[top+1]=ans[0];
    for(int i=0;i<=top;i++)
    {
        while(cross(ans[i+1],ans[q],ans[i])<cross(ans[i+1],ans[q+1],ans[i]))
            q=(q+1)%top;
        res=max(res,max(dist(ans[i],ans[q]),dist(ans[i+1],ans[q+1])));
    }
    return res;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d%d",&pt[i].x,&pt[i].y);
        int k=0;
        for(int i=0;i<n;i++)
        {
            if((pt[k].y>pt[i].y)||(pt[k].y==pt[i].y&&pt[k].x>pt[i].x)) k=i;
        }
        swap(pt[0],pt[k]);
        int top=graham(n);
        int res=qiake(top);
        printf("%d\n",res);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值