【前缀后缀和+位运算】2017ACM/ICPC广西邀请赛 E - CS Course HDU - 6186

2017ACM/ICPC广西邀请赛 E - CS Course HDU - 6186

Little A has come to college and majored in Computer and Science. 

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework. 

Here is the problem: 

You are giving n non-negative integers a1,a2,⋯,ana1,a2,⋯,an, and some queries. 

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except apap. 

Input

There are no more than 15 test cases. 

Each test case begins with two positive integers n and p 
in a line, indicate the number of positive integers and the number of queries. 

2≤n,q≤1052≤n,q≤105 

Then n non-negative integers a1,a2,⋯,ana1,a2,⋯,an follows in a line, 0≤ai≤1090≤ai≤109 for each i in range[1,n]. 

After that there are q positive integers p1,p2,⋯,pqp1,p2,⋯,pqin q lines, 1≤pi≤n1≤pi≤n for each i in range[1,q].

Output

For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except apap in a line. 

Sample Input

3 3
1 1 1
1
2
3

Sample Output

1 1 0
1 1 0
1 1 0

//十万个数,十万次查询,问去掉x位的数 的其他所有数的& |  ^值是多少

保留前缀保留后缀就好了

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+10;
int a[maxn],andd[maxn],orr[maxn];
int andd1[maxn],orr1[maxn];
int xorr;
int main()
{
    int n,m,x;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            if(i==1)
            {
                andd[i]=orr[i]=xorr=a[i];
            }
            else
            {
                andd[i]=andd[i-1]&a[i];
                orr[i]=orr[i-1]|a[i];
                xorr=xorr^a[i];
            }
            //cout<<i<<" "<<andd[i]<<" "<<orr[i]<<" "<<xorr<<endl;
        }

        for(int i=n; i>=1; i--)
        {
            if(i==n)
            {
                andd1[i]=orr1[i]=a[i];
            }
            else
            {
                andd1[i]=andd1[i+1]&a[i];
                orr1[i]=orr1[i+1]|a[i];
            }
            // cout<<i<<" "<<andd1[i]<<" "<<orr1[i]<<endl;
        }

        for(int i=1; i<=m; i++)
        {
            scanf("%d",&x);
            if(x==1)
            {
                printf("%d %d %d\n",andd1[2],orr1[2],xorr^a[1]);
            }
            else if(x==n)
            {
                printf("%d %d %d\n",andd[n-1],orr[n-1],xorr^a[n]);
            }
            else
            {
                printf("%d %d %d\n",andd[x-1]&andd1[x+1],orr[x-1]|orr1[x+1],xorr^a[x]);
            }
        }
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值