【bitset优化+next_permutation预处理】问你是否有合适的状态用灯牌亮暗  ZOJ - 3954 Seven-Segment Display

G - Seven-Segment Display

 ZOJ - 3954 

A seven segment display, or seven segment indicator, is a form of electronic display device for displaying decimal numerals that is an alternative to the more complex dot matrix displays. Seven segment displays are widely used in digital clocks, electronic meters, basic calculators, and other electronic devices that display numerical information.

The segments of a seven segment display are arranged as a rectangle of two vertical segments on each side with one horizontal segment on the top, middle, and bottom. If we refer the segments as the letters from a to g, it's possible to use the status of the segments which is called a seven segment code to represent a number. A standard combination of the seven segment codes is shown below.

 

Xabcdefg
11001111
20010010
30000110
41001100
50100100
60100000
70001111
80000000
90000100
   
0 = on  1 = off

A seven segment code of permutation p is a set of seven segment code derived from the standard code by rearranging the bits into the order indicated by p. For example, the seven segment codes of permutation "gbedcfa" which is derived from the standard code by exchanging the bits represented by "a" and "g", and by exchanging the bits represented by "c" and "e", is listed as follows.

Xgbedcfa
11011011
20000110
30010010
40011001
50110000
60100000
71011010
80000000
90010000

We indicate the seven segment code of permutation p representing number x as cp, x. For example cabcdefg,7 = 0001111, and cgbedcfa,7 = 1011010.

Given n seven segment codes s1, s2, ... , sn and the numbers x1, x2, ... , xn each of them represents, can you find a permutation p, so that for all 1 ≤ i ≤ n, si = cp,xi holds?

Input

The first line of the input is an integer T (1 ≤ T ≤ 105), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains an integer n (1 ≤ n ≤ 9), indicating the number of seven segment codes.

For the next n lines, the i-th line contains a number xi (1 ≤ xi ≤ 9) and a seven segment code si (|si| = 7), their meanings are described above.

It is guaranteed that ∀ 1 ≤ i < j ≤ n, xi ≠ xj holds for each test case.

Output

For each test case, output "YES" (without the quotes) if the permutation p exists. Otherwise output "NO" (without the quotes).

Sample Input

3
9
1 1001111
2 0010010
3 0000110
4 1001100
5 0100100
6 0100000
7 0001111
8 0000000
9 0000100
2
1 1001111
7 1010011
2
7 0101011
1 1101011

Sample Output

YES
NO
YES

Hint

For the first test case, it is a standard combination of the seven segment codes.

For the second test case, we can easily discover that the permutation p does not exist, as three in seven bits are different between the seven segment codes of 1 and 7.

For the third test case, p = agbfced.

 

bitset用法:
b.any() : b中是否存在置为1的二进制位?
b.count() : b中置为1的二进制个数
b.set() : 把b中的所有二进制位都置为1
b.reset() : 把b中的所有二进制位都置为0
b.flip : 把b中所有的二进制逐位取反


dp[i][j][k]:i这个7位的二进制数能否代表j这个数,这是第k种状态


#include <bits/stdc++.h>
using namespace std;
const int maxn=5044;
bitset <maxn> dp[130][10],ans;
int t[10];
int vis[10];
void work(int state)
{

    for(int i=0;i<(1<<7);i++)
    {
        memset(vis,0,sizeof vis);
        for(int j=0;j<7;j++)
        {
            if(!((i>>j)&1)) vis[t[j]]=1;
        }
        if(vis[1]&&vis[2]) dp[i][1][state]=1;
        if(vis[0]&&vis[1]&&vis[3]&&vis[4]&&vis[6]) dp[i][2][state]=1;
        if(vis[0]&&vis[1]&&vis[2]&&vis[3]&&vis[6]) dp[i][3][state]=1;
        if(vis[1]&&vis[2]&&vis[5]&&vis[6]) dp[i][4][state]=1;
        if(vis[0]&&vis[2]&&vis[3]&&vis[5]&&vis[6]) dp[i][5][state]=1;
        if(vis[0]&&vis[2]&&vis[3]&&vis[4]&&vis[5]&&vis[6]) dp[i][6][state]=1;
        if(vis[0]&&vis[1]&&vis[2]) dp[i][7][state]=1;
        if(vis[0]&&vis[1]&&vis[2]&&vis[3]&&vis[4]&&vis[5]&&vis[6]) dp[i][8][state]=1;
        if(vis[0]&&vis[1]&&vis[2]&&vis[3]&&vis[5]&&vis[6]) dp[i][9][state]=1;
    }
}



int main()
{
    int k=0;
    for(int i=0;i<7;i++)
        t[i]=i;
    do{
        work(k);
        k++;
    }while(next_permutation(t,t+7));

    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        ans.set();
        for(int i=1;i<=n;i++)
        {
            int x;
            char s[10];
            scanf("%d%s",&x,s);
            k=0;
            for(int i=0;i<7;i++)
            {
                k=k*2+s[i]-'0';
            }
            ans&=dp[k][x];
        }
        if(ans.any()) printf("YES\n");
        else printf("NO\n");
    }


    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值