【次小生成树】The Unique MST POJ - 1679

The Unique MST POJ - 1679

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int n,m,fa[105];
struct node
{
    int u,v,w;
    int used,repeat,del;
} a[10005];

bool cmp(const node &x,const node &y)
{
    return x.w<y.w;
}

int Find(int x)
{
    if(x==fa[x]) return x;
    return fa[x]=Find(fa[x]);
}

int kruscal(int flag)
{
    int sum=0,tot=0;
    for(int i=1; i<=m; i++)
    {
        if(a[i].del==1) continue;
        int fx=Find(a[i].u),fy=Find(a[i].v);
        if(fx!=fy)
        {
            fa[fx]=fy;
            tot++;
            sum+=a[i].w;
            if(flag==1) a[i].used=1;
        }
        if(tot==n-1) break;
    }
    if(tot==n-1) return sum;
    else return 0;
}


int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            fa[i]=i;

        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&a[i].u,&a[i].v,&a[i].w);
            a[i].used=a[i].del=a[i].repeat=0;
        }

        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(i!=j&&a[i].w==a[j].w)
                {
                    a[i].repeat=a[j].repeat=1;  //记录权值相同的边
                }
            }
        }

        sort(a+1,a+m+1,cmp);

        int ans=kruscal(1);

        int flag=0;
        for(int i=1; i<=m; i++)
        {
            for(int j=1;j<=n;j++)  //记得初始化!
                fa[j]=j;
            if(a[i].repeat&&a[i].used)  //枚举删除被最小生成树用过又有权值相同的边
            {
                a[i].del=1;
                int anss=kruscal(2);
                if(anss==ans)
                {
                    flag=1;
                    printf("Not Unique!\n");
                    break;
                }
                a[i].del=0;
            }
        }



        if(!flag)  printf("%d\n",ans);

    }


    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值