【二分答案】HDU 6581 2019年杭电多校第一场1004 Vacation

http://acm.hdu.edu.cn/showproblem.php?pid=6581

Vacation

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 553    Accepted Submission(s): 178
Special Judge

 

Problem Description

Tom and Jerry are going on a vacation. They are now driving on a one-way road and several cars are in front of them. To be more specific, there are n cars in front of them. The ith car has a length of li, the head of it is si from the stop-line, and its maximum velocity is vi. The car Tom and Jerry are driving is l0 in length, and s0from the stop-line, with a maximum velocity of v0.
The traffic light has a very long cycle. You can assume that it is always green light. However, since the road is too narrow, no car can get ahead of other cars. Even if your speed can be greater than the car in front of you, you still can only drive at the same speed as the anterior car. But when not affected by the car ahead, the driver will drive at the maximum speed. You can assume that every driver here is very good at driving, so that the distance of adjacent cars can be kept to be 0.
Though Tom and Jerry know that they can pass the stop-line during green light, they still want to know the minimum time they need to pass the stop-line. We say a car passes the stop-line once the head of the car passes it.
Please notice that even after a car passes the stop-line, it still runs on the road, and cannot be overtaken.

Input

This problem contains multiple test cases.
For each test case, the first line contains an integer n (1≤n≤105,∑n≤2×106), the number of cars.
The next three lines each contains n+1 integers, li,si,vi (1≤si,vi,li≤109). It's guaranteed that si≥si+1+li+1,∀i∈[0,n−1]

Output

For each test case, output one line containing the answer. Your answer will be accepted if its absolute or relative error does not exceed 10−6.
Formally, let your answer be a, and the jury's answer is b. Your answer is considered correct if |a−b|max(1,|b|)≤10−6.
The answer is guaranteed to exist.

Sample Input

1

2 2

7 1

2 1

2

1 2 2

10 7 1

6 2 1

Sample Output

3.5000000000

5.0000000000

Source

2019 Multi-University Training Contest 1

给你n+1个车子的车长,与线的距离和最大速度

问你在保证车子顺序不变,不超车的情况下,最后一辆车过线的最短时间(可以车头贴着钱一辆车屁股,车过了线还是要保持顺序)

直接二分答案,如果在二分的时间中这辆车的最大时速的距离比前一辆车能到得最大距离大,就让这辆车贴着前一辆车,不然就保持自己最大距离

 

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+10;
const double eps=1e-8;
int n;
double l[maxn],s[maxn],v[maxn];

bool check(double t)
{
    double x=t*v[n+1]-s[n+1]; //第一辆车不受限制,能到的距离
    for(int i=n;i>=1;i--)
    {
        double y=t*v[i]-s[i]; //其他车最大能到距离
        if(y>x-l[i+1]) //超过前一辆车,跟在前一辆车的屁股后面
            x=x-l[i+1];
        else //用自己最大速度
            x=y;
    }
    return x>=0; //最后一辆车头能不能超过线
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n+1;i++)
            scanf("%lf",&l[i]);
        for(int i=1;i<=n+1;i++)
            scanf("%lf",&s[i]);
        for(int i=1;i<=n+1;i++)
            scanf("%lf",&v[i]);

        double l=0,r=1e9;
        double ans=1e9;
        while(r-l>=eps) //二分答案
        {
            double mid=(l+r)/2;
            if(check(mid))
            {
                r=mid;
                ans=mid;
            }
            else l=mid;
        }
        printf("%.9f\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值