【线性基+思维】杭电多校第一场 Operation

http://acm.hdu.edu.cn/showproblem.php?pid=6579

点击进入报名链接)~

Operation

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2840    Accepted Submission(s): 867


 

Problem Description

There is an integer sequence a of length n and there are two kinds of operations:
  • 0 l r: select some numbers from al...ar so that their xor sum is maximum, and print the maximum value.
  • 1 x: append x to the end of the sequence and let n=n+1.
 

 

 

Input

There are multiple test cases. The first line of input contains an integer T(T≤10), indicating the number of test cases.
For each test case: 
The first line contains two integers n,m(1≤n≤5×105,1≤m≤5×105), the number of integers initially in the sequence and the number of operations.
The second line contains n integers a1,a2,...,an(0≤ai<230), denoting the initial sequence.
Each of the next m lines contains one of the operations given above.
It's guaranteed that ∑n≤106,∑m≤106,0≤x<230.
And operations will be encrypted. You need to decode the operations as follows, where lastans denotes the answer to the last type 0 operation and is initially zero: 
For every type 0 operation, let l=(l xor lastans)mod n + 1, r=(r xor lastans)mod n + 1, and then swap(l, r) if l>r.
For every type 1 operation, let x=x xor lastans.

 

 

Output

For each type 0 operation, please output the maximum xor sum in a single line.

 

 

Sample Input

 

1 3 3 0 1 2 0 1 1 1 3 0 3 4

 

 

Sample Output

 

1 3

 

 

//cnt_val[i][j]保存的是[1,i]区间第j位线性基的值
//cnt_pos[i][j]保存的是[1,i]区间第j位线性基的位置
#include <bits/stdc++.h>
using namespace std;
const int maxn=1e6+10;
int a[maxn],d[32],pos[32];
int cnt_pos[maxn][32],cnt_val[maxn][32];

void Insert(int x,int id)
{
    for(int i=30;i>=0;i--)
    {
        if(x&(1<<i))
        {
            if(!d[i])
            {
                d[i]=x;
                pos[i]=id;
                break;
            }
            if(pos[i]<id)
            {
                swap(pos[i],id);
                swap(d[i],x);
            }
            x^=d[i];
        }
    }
}

int query(int l,int r)
{
    int ret=0;
    for(int i=30;i>=0;i--)
    {
        if(cnt_pos[r][i]>=l)
        {
            ret=max(ret,ret^cnt_val[r][i]);
        }
    }
    return ret;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(cnt_pos,0,sizeof(cnt_pos));
        memset(cnt_val,0,sizeof(cnt_val));
        memset(d,0,sizeof(d));
        memset(pos,0,sizeof(pos));
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            Insert(a[i],i);
            for(int j=30;j>=0;j--)
            {
                cnt_pos[i][j]=pos[j];
                cnt_val[i][j]=d[j];
            }
        }
        int ans=0;
        while(m--)
        {
            int op,l,r,x;
            scanf("%d",&op);
            if(op==0)
            {
                scanf("%d%d",&l,&r);
                l=(l^ans)%n+1,r=(r^ans)%n+1;
                if(l>r) swap(l,r);
                ans=query(l,r);
                printf("%d\n",ans);
            }
            else
            {
                scanf("%d",&a[++n]);
                Insert(a[n]^ans,n);
                for(int j=30;j>=0;j--)
                {
                    cnt_pos[n][j]=pos[j];
                    cnt_val[n][j]=d[j];
                }
            }
        }
    }

    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值