HDU 1198 Farm Irrigation

Farm Irrigation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12449    Accepted Submission(s): 5360


 

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

 

Figure 1



Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like

 

Figure 2



Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

 

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

 

Output

For each test case, output in one line the least number of wellsprings needed.

 

Sample Input

2 2

DK

HF

 

3 3

ADC

FJK

IHE

 

-1 -1

 

 

Sample Output

 

2

3

 

 

Author

ZHENG, Lu

 

 

Source

Zhejiang University Local Contest 2005

 

 

判断连通图的数量。DFS,BFS,并查集都可以。这里采用DFS。

具体看代码

#include <cstdio>
#include <string.h>
const int ChMax = 12, Max = 55;
bool connect[ChMax][4] = {{1, 0, 0, 1}, {1, 1, 0, 0}, {0, 0, 1, 1}, {0, 1, 1, 0},
                         {1, 0, 1, 0}, {0, 1, 0, 1}, {1, 1, 0, 1}, {1, 0, 1, 1},
                         {0, 1, 1, 1}, {1, 1, 1, 0}, {1, 1, 1, 1}};         // 各个字母代表地图,按照上右下左顺序,1表示有接口,0表示没有
int Map[Max][Max], op[4][2] = {{-1, 0}, {0, 1}, {1, 0}, {0, -1}};           // 上下左右四个方向
bool visit[Max][Max];
int M, N;

inline bool check(int x, int y)
{
    return (x >= 0 && x < M)&&(y >= 0 && y < N) && !visit[x][y];
}

void dfs(int x, int y)
{
    int con = Map[x][y];
    visit[x][y] = true;
    for(int i = 0; i < 4; i++)
    {
        int xx = x + op[i][0], yy = y + op[i][1];
        if(!check(xx, yy))    continue;
        int newCon = Map[xx][yy];                   // 当前方向所到达的田地
        if(connect[con][i] && connect[newCon][(i + 2) % 4])     // 查看在该方向上是否相通,相通则可以继续搜索
            dfs(xx, yy);
    }
}


int main()
{
    while(~scanf(" %d %d", &M, &N))
    {
        if(M <= 0 || N <= 0)    break;
        char ch;
        for(int i = 0; i <M; i++)
        {
            getchar();
            for(int j = 0; j < N; j++)
            {
                ch = getchar();
                Map[i][j] = ch - 'A';
            }
        }
        memset(visit, 0, sizeof(visit));
        int ans = 0;
        while(true)
        {
            bool flag = false;
            for(int x = 0; x < M; x++)
            {
                for(int y = 0; y < N; y++)
                {
                    if(!visit[x][y])
                    {
                        flag = true;
                        dfs(x, y);
                        ans++;
                    }
                }
            }
            if(!flag)    break;
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值