HDU 1548 A strange lift

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34869    Accepted Submission(s): 12425

 

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

 Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5 3 3 1 2 5 0

Sample Output

3

 

BFS进行搜索,也可以用Dijstra,这里用的是BFS。刚开始时不断的爆内存,原因是刚开始时没有考虑到会出现死循环现象。后来加了个visit数组标记,并以此计算所需要的步数,也可以用结构体进行标记。

 

#include <cstdio>
#include <queue>
#include <string.h>
using namespace std;
int N,A,B;
int a[205],i;
int visit[205];
int op[2]={1,-1};

bool BFS()
{
    queue<int> q;
    q.push(A);                  //起点入队
    int cur,nextf;
    while(!q.empty())
    {
        cur=q.front();          //当前楼层
        q.pop();                
        if(cur==B) return true; //到达终点
        for(int k=0;k<2;k++)    //上下两个方向搜索
        {
            nextf=cur+op[k]*a[cur];
            if(nextf<=N&&nextf>=1&&!visit[nextf])  //范围合理,且未被访问过,visit排除死循环,记录次数
            {
                q.push(nextf);  
                visit[nextf]=visit[cur]+1;   //到达下一楼层所需次数=到达这一楼层次数+1
                if(nextf==B) return true;    //若已经到达,提前结束
            }

        }
    }
    return false;                             //不可到达
}

int main()
{
    while(~scanf("%d",&N)&&N)
    {
        memset(visit,0,sizeof(visit));
        scanf("%d%d",&A,&B);
        visit[A]=1;                          //起点标记为已访问,最后输出次数应该-1
        for(i=1;i<=N;i++)   scanf("%d",&a[i]);
        printf("%d\n",BFS()?visit[B]-1:-1);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值