POJ 3660任意两点之间的最短路 floyd裸题

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M(1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2

方法:用floyd求出任意两点之间的最短路

注意点:1、最后要check两点之间是否有路

              2、此图为有向图

                    故1、应考虑两个方向—> i比j小或i比j大 —>  if (d[i][j] != INF || d[j][i] != EOF)

ac代码:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#define INF 1e9 +7
using namespace std;
int d[111][111];
int minn(int a,int b) {return a > b ? b : a; }
int main()
{
    int N,M;
    while(scanf("%d%d",&N,&M) != EOF)
    {
        int x,y;
        for(int i =1;i<=N;i++)
        {
            for(int j =1;j<=N;j++)
                d[i][j] = INF;
            d[i][i] = 0;
        }
        for(int i = 0;i<M;i++)
        {
            scanf("%d%d",&x,&y);
            d[x][y] = 1;
        }
        for(int k = 1;k<= N;k++)
        {
            for(int i = 1;i<=N;i++)
            {
                for(int j  =1; j <=N;j++)
                    d[i][j] = minn(d[i][j],d[i][k] + d[k][j]);
            }
        }
        int ans = 0;
        for(int i = 1;i<=N;i++)
        {
            int t = 1;
            for(int j =1;j<=N;j++)
            {
                if(d[i][j] == INF && d[j][i] == INF)
                    t = 0;
            }
            if(t)
                ans ++;
        }
        printf("%d\n",ans);
    }
}

                  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值