poj3280(区间dp)

Cheapest Palindrome

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12784 Accepted: 6065

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

 

 

题意:给定一个字符串, 删除或增加某字符需要不同的花费,求使字符串变成回文串的最小花费。

思路: 首先简单思考发现删除或增加某个字符对于让它变成回文串来说是等价的, 所以每个字符就取最小花费。

设 dp[ i ][ j ] 为把 i 到 j 这一区间的字符串变成回文串所需要的最小花费,

如果s[ i ] == s[ j ] , 即区间两个端点的字符相等, 则dp[ i ][ j ] = dp[ i + 1 ][ j - 1]

否则, dp[ i ][ j ] = min( min( dp[ i ][ j ], dp[ i ][ j - 1 ] + cost[ s [ j ] ] ), dp[ i + 1 ][ j ] + cost[ s [ i ] ] )

其中, cost[ s[ i ] ] 为增加或删除s[ i ]的花费。

代码:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxx = 0x3f3f3f3f;
int dp[2048][2048];//i到j变成回文串的最小化费
int cost[150];
int main()
{
    int n, m;
    while(cin>>n>>m)
    {
        string s;
        cin>>s;
        for(int i = 0; i < n; ++i)
        {
            char c; int x, y;
            cin>>c>>x>>y;
            cost[c] = min(x, y);
        }
        for(int i = m - 1; i >= 0; --i)//我觉得比较简洁易懂的区间dp写法,与经典写法不同
        {
            dp[i][i] = 0;
            for(int j = i + 1; j < m; ++j)
            {
                dp[i][j] = maxx;
                if(s[i] == s[j])
                    dp[i][j] = dp[i+1][j-1];
                else
                {
                    dp[i][j] = min(min(dp[i][j], dp[i][j-1] + cost[s[j]]), dp[i+1][j] + cost[s[i]]);
                }
            }
        }
        cout<<dp[0][m-1]<<endl;
    }
    return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值