POJ-1456 贪心+数组优化

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 


Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

 

题目大意:给n个商品,每个商品有利润pi和过期时间di,每天只能卖一个商品,过期就不能再卖,求如何安排获得最大利润?

题解:

贪心一下,优先卖出最高利润产品并让每个产品尽可能晚的卖出去。数据量只有1e4,容易想到用一个visit数组表示某天是否被占用,对于每个商品从最后期限往前找第一个没被占用的时间。但是暴力找复杂度显然爆炸,就需要优化一下

网上许多题解给出了贪心+堆优化或者并查集优化,这里用另一种方法优化。

用nxt[ i ]表示第i天被占用后的下一个可用天数,初始就是nxt[ i ] = i - 1, 而后动态更新。详见代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxx = 1e4 + 5;
struct Node
{
    int p, d;
}a[maxx];
bool cmp(Node x, Node y)
{
    return x.p > y.p;
}
bool vis[maxx];
int nxt[maxx];
int main()
{
    int n;
    while(~scanf("%d", &n))
    {
        memset(vis, 0, sizeof(vis));
        for(int i = 0; i < n; ++i)
        {
            nxt[i] = i-1;
            scanf("%d%d", &a[i].p, &a[i].d);
        }
        sort(a, a + n, cmp);
        int sum = 0;
        for(int i = 0; i < n; ++i)
        {
            int it = a[i].d;
            while(it && vis[it])
                it = nxt[it];
            if(!it)
                continue;
            vis[it] = true;
            sum += a[i].p;
            nxt[a[i].d] = it - 1;
        }
        printf("%d\n", sum);
    }
    return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值