Just a Hook

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.


Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

解析:这道题题中有几个需要注意的点,一刚开始的初始状态都是铜棒所以数值为1,二后面的条件是替换之前的金属棒,不是合并,理解好题意,会发现这道题并不难,只是线段树的一点点变形。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define maxn 100000
struct node
{
    int w,f;
} tree[4*maxn+10];
void build(int k,int l,int r)//建树
{
    tree[k].w=1;
    tree[k].f=0;
    if(l==r)
        return ;
    int m=(l+r)/2;
    build(2*k,l,m);
    build(2*k+1,m+1,r);
    tree[k].w=tree[2*k].w+tree[2*k+1].w;
}
void down(int k,int l,int r)//这里的l,r还可以写在结构里面,那样可能更好理解
{
    tree[2*k].f=tree[2*k+1].f=tree[k].f;
    int m=(l+r)/2;
    tree[2*k].w=tree[k].f*(m-l+1);
    tree[2*k+1].w=tree[k].f*(r-m);
    tree[k].f=0;
}
void add(int k,int l,int r,int x,int y,int w)//区间更改
{
    if(l>=x&&r<=y)
    {
        tree[k].w=w*(r-l+1);
        tree[k].f=w;
        return ;
    }
    if(tree[k].f)
        down(k,l,r);
    int m=(l+r)/2;
    if(x<=m)
        add(2*k,l,m,x,y,w);
    if(y>m)
        add(2*k+1,m+1,r,x,y,w);
    tree[k].w=tree[2*k].w+tree[2*k+1].w;
}
int main()
{
    int t,n,q,ca=1;
    scanf("%d",&t);
    while(t--)
    {
        memset(tree,0,sizeof(tree));
        scanf("%d%d",&n,&q);
        int x,y,w;
        build(1,1,n);
        while(q--)
        {
            scanf("%d%d%d",&x,&y,&w);
            add(1,1,n,x,y,w);
        }
        printf("Case %d: The total value of the hook is %d.\n",ca++,tree[1].w);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值