第十一届河南ACM Gene mutation(模拟)

6 篇文章 0 订阅

提交地址:点击打开链接

 
 

Gene mutation is the sudden and inheritable mutation of genomic DNA molecules. From the molecular level, gene mutation refers to the change of the composition or sequence of base pairs in the structure of a gene. Although the gene is very stable, it can reproduce itself accurately when the cell divides. Under certain conditions, the gene can also suddenly change from its original existence to another new form of existence.

 

A genome sequence might provide answers to major questions about the biology and evolutionary history of an organism.  A 2010 study found  a gene sequence in the skin of cuttlefish  similar to those in the eyes retina. If the gene matches, it can be used to treat certain diseases of the eye.

 

A gene sequence in the skin of cuttlefish  is specified by a sequence of distinct integers (Y1,Y2, …Yc). it  may be mutated. Even if these integers are transposed  ( increased or decreased by a common amount ) ,  or re-ordered ,  it is still a gene sequence of cuttlefish.  For example,  if  "4 6 7"  is a gene sequence of cuttlefish, then "3 5 6" (-1), "6 8 9" ( +2),  "6 4 7" (re-ordered), and "5 3 6" (transposed and re-ordered) are also ruminant a gene sequence of cuttlefish.

 

Your task is to determine that there are several matching points at most  in a gene sequence of the eyes retina (X1,X2, , Xn)

输入

 
 

The first line of the input contains one integer T, which is the number of  test cases (1<=T<=5).  Each test case specifies:

* Line 1:       n                   ( 1 ≤ n ≤ 20,000 )

* Line 2:       X1  X2… Xn        ( 1 ≤ Xi ≤ 100    i=1…. n)

* Line 3:       c                   ( 1 ≤ c≤ 10 )

* Line 4:       Y1  Y2… Yc        ( 1 ≤ Yi ≤ 100    i=1…. c)

输出

 
 

For each test case generate a single line:  a single integer that there are several matching points. The matching gene sequence can be partially overlapped

样例输入

复制
161 8 5 7 9 1034 6 7

样例输出

复制
2

排序,再扫一遍数组就行了

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n1,n2,cnt=0;
		int a[20010],b[106],c[106];
		cin>>n1;
		for(int i = 0;i<n1;i++)
			cin>>a[i];
		cin>>n2;
		for(int i = 0;i<n2;i++)
			cin>>b[i];
		sort(b,b+n2);
		int tmp = b[0];
		for(int i = 0;i< n2;i++)
			b[i] = b[i]-tmp;
	//	for(int i = 0;i< n2;i++)
	//		cout<<b[i]<<" ";
		//	cout<<'\n';
		for(int i = 0;i<n1-n2+1;i++)
		{
			for(int j = 0,k=i;j<n2;j++)
			{
				c[j] = a[k++];
			}
			sort(c,c+n2);
			tmp = c[0];
			int flag = true;
			for(int j =0;j<n2;j++)
			{
				c[j] = c[j]- tmp; // cout<<c[j]<<' ';
				if(c[j]!=b[j]) {
					flag = false;
			
				}
			}
			if(flag) cnt++;
		}
	    cout<<cnt<<endl;
	}
	return 0;
}
/*
1
6
1 8 5 7 9 10
3
4 6 7
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值