HDU 1686 - Oulipo(KMP和拓展KMP)

题目链接:Click me!

                                                 Oulipo

                     Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                    Total Submission(s): 28371    Accepted Submission(s): 10871

 

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
 

 

Sample Input

3

BAPC

BAPC

AZA

AZAZAZA

VERDI

AVERDXIVYERDIAN

Sample Output

1

3

0

 

题意解析:

本题题意就是给你两个串,先给出副串后给出主串,找副串在主串的个数,有个需要注意的点,就是匹配的时候可以重叠。

 

思路解析:

就是普通的KMP和拓展KMP,最好用拓展KMP,因为此题数据有点大,所以拓展KMP更保险一点。然后匹配完回退的时候, j = next[j] 就行了。

然后此题有一个特别大的坑,本来我看数据,主串 1000000,副串 10000,我就每个增加了 5 的容量,但是一直提示我超时...然后我一直优化我的KMP,优化到不能再优化,还是不让过,然后我就感觉到事情不简单,把数组加了个 0,过了......

 

代码篇:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int len1, len2;
int nt[100005];
char brr[100005], arr[10000005];
void getnext()
{
    int j = 0, k = -1;
    nt[j] = k;
    while(j < len2)
    {
        if(k == -1 || brr[j] == brr[k])
        {
            j++;
            k++;
            if(brr[j] != brr[k]) ///拓展KMP的精髓
                nt[j] = k;
            else
                nt[j] = nt[k];
        }
        else
            k = nt[k];
    }
}
int main()
{
    int n, i, j, ans;
    cin >> n;
    while(n--)
    {
        cin >> brr >> arr;
        len1 = strlen(arr), len2 = strlen(brr);
        getnext();
        i = 0, j = 0, ans = 0;
        while(i < len1)     ///i为主串指针,j为副串指针
        {
            if(j == len2)
            {
                ans++;      ///回退的时候,退到当前匹配字符的next值
                j = nt[j];  ///因为匹配可以重叠
            }
            if(arr[i] == brr[j] || j == -1)
            {
                i++;
                j++;
            }
            else
                j = nt[j];
        }
        if(i == len1 && j == len2) ///一样的判断最后一次是否匹配
            ans++;
        cout << ans << endl;
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值