Cyclic Nacklace
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19662 Accepted Submission(s): 8012
Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.
As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:
Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
Sample Input
3
aaa
abca
abcde
Sample Output
0
2
5
题意解析:
题意就是给出一个项链,需要你去求出加多少珠子,才可以让项链形成一个循环手链(也就是形成N段相同的部分)
做法解析:
也就是用next数组来求循环节,然后求出需要加几颗珠子即可。
代码篇:
#include <iostream>
#include <cstring>
using namespace std;
int nt[100010], len;
char arr[100010];
void getnext() ///求next数组
{
int j = 0, k = -1;
nt[0] = -1;
while(j < len)
{
if(k == -1 || arr[j] == arr[k])
{
j++;
k++;
nt[j] = k;
}
else
k = nt[k];
}
}
int main()
{
ios::sync_with_stdio(false); ///用来解决cincout超市问题
int n;
cin >> n;
while(n--)
{
cin >> arr;
len = strlen(arr);
memset(nt, 0, sizeof(nt));
getnext();
if(nt[len] == 0) ///说明要补充整个串
cout << len << endl;
else
{
int ans = len - nt[len]; ///循环节
if(len % ans == 0)
cout << 0 << endl;
else
cout << ans - len % ans << endl; ///求出还需要补充几个
}
}
return 0;
}
OVER!