HDU 4280 Island Transport ISAP+bfs 初始化 + 栈优化

12 篇文章 0 订阅
3 篇文章 0 订阅

Island Transport

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 11917    Accepted Submission(s): 3802


 

Problem Description

  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.

 

 

Input

  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.

 

 

Output

  For each test case, output an integer in one line, the transport capacity.

 

 

Sample Input

 
2
5 7
3 3
3 0
3 1
0 0
4 5
1 3 3
2 3 4
2 4 3
1 5 6
4 5 3
1 4 4
3 4 2
6 7
-1 -1
0 1
0 2
1 0
1 1
2 3
1 2 1
2 3 6
4 5 5
5 6 3
1 4 6
2 5 5
3 6 4

 

Sample Output

 

9

6

 

 

Source

2012 ACM/ICPC Asia Regional Tianjin Online

 

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  4277 4267 4268 4269 4270 

 

#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define MST(a,b) memset(a,b,sizeof(a))
typedef long long ll;
const ll mod=1e4;
const int L=26,maxn=100050;
int n,m,k,T;
struct Edge {
	int to,next,cap,flow;//cap:盖子就是在建图的时候如果需要建立回路那么就传入addege(u,v,w,w);,这样比传两遍快。
} edge[maxn*4];
int tol,head[maxn],gap[maxn],dep[maxn],S[maxn],cur[maxn];
void init() { //初始化
	tol=0,MST(head,-1);
}
void addedge(int u,int v,int w,int rw=0) { //建图
	edge[tol].to=v;
	edge[tol].cap=w;
	edge[tol].next=head[u];
	edge[tol].flow=0;
	head[u]=tol++;
	edge[tol].to=u;
	edge[tol].cap=rw;
	edge[tol].next=head[v];
	edge[tol].flow=0;
	head[v]=tol++;
}
int Q[maxn];
void bfs(int st,int en) {
	MST(dep,-1),MST(gap,0);
	memset(gap,0,sizeof(gap));
	gap[0]=1;
	int front=0,rear=0;
	dep[en]=0,Q[rear++]=en;
	while(front!=rear) {
		int u=Q[front++];
		for(int i=head[u]; i!=-1; i=edge[i].next) {
			int v=edge[i].to;
			if(dep[v]!=-1) continue;
			Q[rear++]=v;
			dep[v]=dep[u]+1;
			gap[dep[v]]++;
		}
	}
}
int sap(int st,int en,int N) {
	bfs(st,en);
	memcpy(cur,head,sizeof(head));
	int top=0,u=st,ans=0;
	while(dep[st]<N) {
		if(u==en) {
			int Min=INF,inser;
			for(int i=0; i<top; i++)
				if(Min>edge[S[i]].cap-edge[S[i]].flow)
					Min=edge[S[i]].cap-edge[S[i]].flow,inser=i;
			for(int i=0; i<top; i++)
				edge[S[i]].flow+=Min,edge[S[i]^1].flow-=Min;
			ans+=Min,top=inser,u=edge[S[top]^1].to;
			continue;
		}
		bool flag=false;
		int v;
		for(int i=cur[u]; i!=-1; i=edge[i].next) {
			v=edge[i].to;
			if(edge[i].cap-edge[i].flow&&dep[v]+1==dep[u]) {
				flag=true,cur[u]=i;
				break;
			}
		}
		if(flag) {
			S[top++]=cur[u];
			u=v;
			continue;
		}
		int Min=N;
		for(int i=head[u]; i!=-1; i=edge[i].next)
			if(edge[i].cap-edge[i].flow&&dep[edge[i].to]<Min)
				Min=dep[edge[i].to],cur[u]=i;
		gap[dep[u]]--;
		if(!gap[dep[u]]) return ans;
		dep[u]=Min+1,gap[dep[u]]++;
		if(u!=st) u=edge[S[--top]^1].to;
	}
	return ans;
}
int main() {
	int start,End;
	int m;
	int u,v,z;
	int T;
	scanf("%d",&T);
	while(T--) {
		init();
		scanf("%d %d",&n,&m);
		int minx=10000000;
		int maxx=-10000000;
		int x,y;
		for(int i=1; i<=n; i++) {
			scanf("%d %d",&x,&y);
			if(minx>x) {
				minx=x;
				start=i;
			}
			if(maxx<x) {
				maxx=x;
				End=i;
			}
		}
		while(m--) {
			scanf("%d%d%d",&u,&v,&z);
			addedge(u,v,z,z);
		}
		int ans=sap(start,End,n);
		printf("%d\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值