Arbitrage

*源于 POJ - 2240

 

                                    

                                                        Arbitrage

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

原题翻译:

套利是利用货币汇率的差异将一个货币单位转换为同一货币的一个以上单位。例如,假设1美元买入0.5英镑,1英镑买入10.0法国法郎,1法国法郎买入0.21美元。然后,通过兑换货币,聪明的交易者可以从1美元开始买入0.5 * 10.0 * 0.21 = 1.05美元,获利5%。

您的工作是编写一个程序,将一系列货币汇率作为输入,然后确定套利是否可行。
输入
输入将包含一个或多个测试用例。在每个测试用例的第一行,有一个整数n(1 <= n <= 30),表示不同货币的数量。接下来的n行包含一种货币的名称。在名称中不会出现空格。下一行包含一个整数m,表示要遵循的表的长度。最后m行各自包含源货币的名称ci,实数 rij 表示从ci到cj的汇率以及目的地货币的名称cj。表中没有出现的交换是不可能的。
测试用例通过空行彼此分开。对于n,输入以零(0)的值终止。
产量
对于每个测试用例,分别以“案例:是”格式打印一行,告知是否可以套利“案例:否”。

思路:把所有的货币自己到自己的值设为1,即e[i][i]=1,能够交换的给e[i][j]赋值,不能交换的设为0;由题意和数据(n<30)可以采用floy算法。推出公式:    if(e[i][j]<e[i][k]*e[k][j])
                                             e[i][j]=e[i][k]*e[k][j];

一圈下来,如果自己到自己的交换率cha超过了1,则说明能够套利。

注意:此题要和 map 的知识点结合,我也写了一篇,希望对你有帮助(点击 map)

代码如下:

#include <iostream>
#include <map>
#include <cstring>
#include <string>
using namespace std;

int main()
{
    double e[35][35];
    int n;
    map<string,int>exchange_rate;
int num=0;
    while (cin>>n&&n!=0)
    {


        memset(e,0,sizeof(e));
        for(int i=1; i<=n; i++)
            e[i][i]=1;

        num++;
        int p=1;
        string currency ;
        for(int i=0; i<n; i++)
        {
            cin >>currency;
            exchange_rate.insert(make_pair(currency,p++));  
        }

        int m;
        cin >>m;
        for(int i=0; i<m; i++)
        {
            string a,c;
            double b;
            cin >>a>>b>>c;

            e[exchange_rate[a]][exchange_rate[c]]=b;
        }

        for(int k=1; k<=n; k++)
            for(int i=1; i<=n; i++)
                for(int j=1; j<=n; j++)
                    if(e[i][j]<e[i][k]*e[k][j])
                        e[i][j]=e[i][k]*e[k][j];
        int cis=0;
        for(int i=1; i<=n; i++)
            if(e[i][i]>1)
            {
                cis++;
            }

        if(cis==0)
            cout <<"Case "<<num<<": No"<<endl;
        else
            cout <<"Case "<<num<<": Yes"<<endl;

            exchange_rate.clear();

    }

    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值