【题解】HDU 1075 What Are You Talking About

题目描述

目录

题目描述

题意分析

AC代码


Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

Output

In this problem, you have to output the translation of the history book.

Sample Input

START

from fiwo

hello difh

mars riwosf

earth fnnvk

like fiiwj

END

START

difh, i'm fiwo riwosf.

i fiiwj fnnvk!

END

 

Sample Output

hello, i'm from mars.

i like earth!

 

题意分析

题意:给你 地球语 以及 相对应的火星语 ,叫你把火星语翻译一下输出。

           STL MAP,截取单词,并于MAP中寻找,若找到则转化输出即可

           要求使用scanf 但我一直编译错误,用了cin就OK 了,有思路的同学,欢迎下方留言

 

AC代码

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <map>
using namespace std;

map <string,string> s;

int main()
{
    string q,p,r;       
    string s2,s3;
    int i;

    cin>>r;
    while( cin>>p )
    {
        if(p=="END")break;

        cin>>q;
        s[q] = p;
    }

    cin>>r;
    getline(cin,s2);
    while(getline(cin,s2))
    {
        if(s2=="END")break;
        s3="";
        for(i=0;i<s2.size();i++)
        {
            if( isalpha(s2[i]) )
            {
                s3+=s2[i];
            }
            else                    //于MAP中搜索判定  
            {
                if(s[s3]!="")
                {
                    cout<<s[s3];
                }
                else
                {
                    cout<<s3;
                }
                cout<<s2[i];       //须将此将非字母输出  并将字符串赋空
                s3="";
            }
        }
        cout<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值