HDU 3829 Cat VS Dog 最大独立集

64 篇文章 0 订阅
24 篇文章 0 订阅

一、内容

 The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input

The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)

Output

For each case, output a single integer: the maximum number of happy children.

Sample Input

1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output

1
3

二、思路

  • 我们按照孩子进行建边。 若一个孩子喜欢的和另一个孩子不喜欢的相同,那么就建立一条边。 然后最后求一下最大匹配x。代表这x对只能满足一人,那么总共满足人数 = 总点数 - x

三、代码

#include <cstdio>
#include <cstring>
using namespace std;
const int N = 505;
int n, c, d, g[N][N], mat[N];
char like[N][5], dlike[N][5];
bool vis[N];
bool dfs(int u) {
	for (int v = 1; v <= n; v++) {
		if (vis[v] || !g[u][v]) continue; vis[v] = true;
		if (!mat[v] || dfs(mat[v])) {
			mat[v] = u;  return true;
		}
	}
	return false;
}
int main() { 
	while (~scanf("%d%d%d", &c, &d, &n)) {
		memset(g, 0, sizeof(g));
		memset(mat, 0, sizeof(mat));
		for (int i = 1; i <= n; i++) {
			scanf("%s%s", like[i], dlike[i]);
		}
		//建立二分图 若2个孩子的喜好相反
		for (int i = 1; i <= n; i++) {
			for (int j = 1; j <= n; j++) {
				if (!strcmp(like[i], dlike[j]) || !strcmp(dlike[i], like[j])) g[i][j] = g[i][j] = 1;
			}
		} 
		int ans = 0; //求最大独立集 有多少个孩子匹配 那么说明只能取其一
		for (int i = 1; i <= n; i++) {
			memset(vis, false, sizeof(vis));
			if (dfs(i)) ans++;
		} 
		printf("%d\n", n - ans / 2);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值