【HDU - 1856】 More is better(并查集)(还需要空间优化。。)

81 篇文章 1 订阅
39 篇文章 0 订阅

题干:

Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements. 

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way. 
InputThe first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)OutputThe output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
Sample Output
4
2


        
  
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

解题报告:    

    裸一个并查集,最后查的时候记录一下最大值就好了。

ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
const int MAX = 10000000 + 5;
using namespace std;

int f[MAX];
int sum[MAX];
int getf(int v) {
	return f[v]==v? v : f[v]=getf( f[v] ) ;
}
void merge(int u,int v) {
	int t1,t2;
	t1=getf(u);t2=getf(v);
	if(t1!=t2) {
		f[t2]=t1;
	}
	
}
void init() {
	for(int i = 0; i<MAX; i++) {
		f[i]=i;
		sum[i]=0;
	}
}
int maxx,u,v;
int main()
{
	int n;
	while(~scanf("%d",&n)) {
		if(n==0) {
			printf("1\n");
			continue;	
		}
		init();
		maxx=0;
		while(n--) {
			scanf("%d %d",&u,&v);
			merge(u,v);
			if(u>maxx||v>maxx) maxx=max(u,v);
		}
		for(int i = 1; i<=maxx; i++) {
			sum[getf(f[i])] ++;
		}
		printf("%d\n",*max_element(sum+1,sum+maxx+1));
		
	}
	
	return 0 ;
 } 

ac代码2:(空间优化了一点点,只开了一个数组)

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

int pre[10000005];
int fin(int x)
{
    if(pre[x]==x)
    {
        return x;
    }
    else
    {
        return pre[x]=fin(pre[x]);
    }
}

void join(int x,int y)
{
    int t1=fin(x);
    int t2=fin(y);
    if(t1!=t2)
    {
        pre[t1]=t2;
    }
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)//特判,被坑在这了
        {
            printf("1\n");
            continue;
        }
        int maxn=0,a,b;
        for(int i=0;i<=10000004;i++)
        {
            pre[i]=i;
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            join(a,b);
            if(max(a,b)>maxn)//优化技巧
            {
                maxn=max(a,b);
            }
        }
        int sum=0,sum1=0;
        for(int i=1;i<=maxn;i++)
        {
            sum1=0;
            if(pre[i]==i)
            for(int j=1;j<=maxn;j++)
            {
                if(i==fin(j))
                {
                    sum1++;
                }
            }
            sum=max(sum,sum1);//更细最大值
        }
        printf("%d\n",sum);
    }
    return 0;
}

总结:

    n==0时别忘特殊处理一下!!!

    有个地方时间优化的十分正确  maxx的记录。

    还可以再时间优化:merge的时候,在合并点的同时(t2合并入t1),sum[t1]+=sum[t2];(即把t2的成员也都加入t1)

    有个缺点 占内存太多啦!有没有更好的方法?

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值