【POJ - 3273 】Monthly Expense (二分,最小最大值)

49 篇文章 0 订阅

题干:

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题目大意:

给你一个长度为N的序列,现在需要把他们切割成M个子序列(所以每一份都是连续的),使得每个子序列和均不超过某个值X,输出X的最小值。

换句话说,切成M份,然后每一份都有一个和sum[i],其中最大的一个是maxSum = max(sum[i]),问这个最大值最小是多少?

 

解题报告:

    刚开始读题以为要加点贪心,后来发现是要切割数组,所以是连续的,不能排序、、、白白WA一发、、

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream> 
#define ll long long
using namespace std;
ll sum,a[100005];
ll n,m;
bool ok(ll lim) {
	int cnt = 0;
	ll cur = 0;
	for(int i = 1; i<=n; i++) {
		if(cur + a[i] <= lim) {
			cur+= a[i];
		}
		else {
			cnt++;
			cur=0;
			i--;
		}
	}
	if(cnt >= m) return 0;
	else return 1;
}
int main()
{

	cin>>n>>m;
	for(int i = 1; i<=n; i++) scanf("%lld",a+i),sum += a[i];
//	sort(a+1,a+n+1);
	ll l = *max_element(a+1,a+n+1),r = sum;
	ll mid = (l+r)/2;
	while(l < r) {
		mid = (l+r)/2;
		if(ok(mid)) r=mid;
		else l=mid+1; 
	}
	printf("%lld\n",l);
	return 0 ;
 } 

2020/1/29再做:

还是WA了一发,是因为下界写成了0,其实不能是0,因为当l为特别小的值的时候有可能被认为合法。

比如这个样例:

5 5
1 10000 3 4 5

如果你代码这么写,则会输出1

或者采用这样的方法避免修改下界。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define FF first
#define SS second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
const int MAX = 2e5 + 5;
typedef pair<int,int> PII;
int n,k,a[MAX];
bool ok(ll x) {
	int cnt = 1; ll cur = 0;
	for(int i = 1; i<=n; i++) {
		if(cur + a[i] <= x) cur += a[i];
		else {
			cnt ++,cur = a[i];
			if(cur > x) return 0;
		}
	}
	return cnt <= k;
}
int main()
{
	while(cin>>n>>k) {
		for(int i = 1; i<=n; i++) cin>>a[i];
		ll l = 0,r = 1e12,ans,mid;
		while(l<=r) {
			mid = (l+r)>>1;
			if(ok(mid)) r = mid - 1,ans = mid;
			else l = mid + 1;
		}
		printf("%lld\n",ans);		
	}
	
	return 0 ;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值