51NOD 1163——最高的奖励

有N个任务,每个任务有一个最晚结束时间以及一个对应的奖励。在结束时间之前完成该任务,就可以获得对应的奖励。完成每一个任务所需的时间都是1个单位时间。有时候完成所有任务是不可能的,因为时间上可能会有冲突,这需要你来取舍。求能够获得的最高奖励。

 

Input
第1行:一个数N,表示任务的数量(2 <= N <= 50000) 

第2 - N + 1行,每行2个数,中间用空格分隔,表示任务的最晚结束时间Ei以及对应的奖励Wi。(1 <= Ei <= 10^9,1 <= Wi <= 10^9)

 

Output

输出能够获得的最高奖励。

 

Sample Input
7
4 20
2 60
4 70
3 40
1 30
4 50

6 10

 

Sample Output

230

Ps:本题要运用贪心思想,要在完成时间前获得奖励最高,具体看代码表现。

AC代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;
struct node
{
    int x,y;
} ;
int cmp1(node a,node b)
{
    if(a.x==b.x)
        return a.y>b.y;
    return a.x<b.x;
}
struct cmp
{
    bool operator ()(node a,node b)
    {
        return a.y>b.y;
    }
};
int main()
{
    int n;
    node a[50005];
    cin>>n;
    for(int i=0; i<n; i++)
        cin>>a[i].x>>a[i].y;
    priority_queue<node,vector<node>,cmp>q;
    sort(a,a+n,cmp1);
    int t=0;
    for(int i=0; i<n; i++)
    {
        if(t<a[i].x)
        {
            q.push(a[i]);
            t++;
        }
        else if(t==a[i].x)
        {
            if(a[i].y>q.top().y)
            {
                q.pop();
                q.push(a[i]);
            }
        }
    }
    ll sum=0;
    while(!q.empty())
    {
        sum+=q.top().y;
        q.pop();
    }
    cout<<sum<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值