HDU 1880 魔咒词典(Hash+二分)

题目链接

哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。 

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

Input

首先列出词典中不超过100000条不同的魔咒词条,每条格式为: 

[魔咒] 对应功能 

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。 
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

Sample Input

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output

light the wand
accio
what?
what?

中文题,题意就不用说了。

题解:现在我们定义两个结构体数组,保存字符串转换后的值,和对应编号。我们提前将“魔咒”和“对应功能”的hash值算出来然后保存下来,然后按hash值从小到大排序,然后后面输入需要查找的,直接去对应数组二分查找就好了,思想很好理解,注意:要是输入的对应功能,要求输出魔咒时,没有那个中括号,细节看代码。

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<set>
#include<cmath>
#include<stack>
#include<string>
const int maxn=1e5+10;
const int mod=1e9+7;
const int inf=1e8;
#define me(a,b) memset(a,b,sizeof(a))
#define lowbit(x) x&(-x)
#define mid l+(r-l)/2
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
#define PI 3.14159265358979323846
int dir[4][2]= {0,-1,-1,0,0,1,1,0};
typedef long long ll;
using namespace std;
char str1[maxn][30],str2[maxn][100];
int len=0;
struct node
{
    int has,i;
    bool friend operator<(node a,node b)
    {
        return a.has<b.has;
    }
}cnt1[maxn],cnt2[maxn];///cnt1保存魔咒的hash值,cnt2保存对应功能的hash值
int gethash(char *str)///算一个字符串的hash值
{
    int sum=0,seed=131;
    int l=strlen(str);
    for(int i=0;i<l;i++)
        sum=sum*seed+str[i];
    return sum;
}
void solve()///将魔咒和对应功能的字符串转化成相应的hash值
{
    for(int i=0;i<len;i++)
    {
        cnt1[i].has=gethash(str1[i]);
        cnt2[i].has=gethash(str2[i]);
        cnt1[i].i=cnt2[i].i=i;
    }
    sort(cnt1,cnt1+len);///排序,方便后面二分查找。
    sort(cnt2,cnt2+len);
}
int main()
{
    while(scanf("%s",str1[len])&&strcmp(str1[len],"@END@"))
    {
        getchar();
        gets(str2[len++]);
    }
    solve();
    int n;
    scanf("%d",&n);
    getchar();
    for(int i=0;i<n;i++)
    {
        char str[105];
        gets(str);
        node temp;
        if(str[0]=='[')
        {
            temp.has=gethash(str);
            int pos=lower_bound(cnt1,cnt1+len,temp)-cnt1;///输入的魔咒,在对应数组里面找
            if(temp.has==cnt1[pos].has)
                printf("%s\n",str2[cnt1[pos].i]);///若有这个魔咒,输出对应的功能
            else
                printf("what?\n");
        }
        else
        {
            temp.has=gethash(str);
            int pos=lower_bound(cnt2,cnt2+len,temp)-cnt2;///跟上面原理一样
            if(temp.has==cnt2[pos].has)
            {
                int len=strlen(str1[cnt2[pos].i]);
                str1[cnt2[pos].i][len-1]='\0';///这步和下面的+1都是为了不输出那个中括号
                printf("%s\n",str1[cnt2[pos].i]+1);
            }
            else
                printf("what?\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值