1072 Gas Station (30 分)

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10^​3​​), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10^​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

 

题目大意:给你n个房屋和m个候选加油站,k条路组成一幅无向图,让你选出最佳的一个候选加油站。此加油站离房屋最近的人最远,且要在服务范围ds之内。如果有多个,输出平均距离最近的那个,还有多个就输出编号最小的那个;不存在就输出No Solution.

分析:把加油站编号按n+i读入,然后对m个候选加油站跑Dijkstra算法即可。

(小技巧:stoi(s)快速字符s转数字、s.substr(i)从s第i位截取到末尾)

#include<bits/stdc++.h>
using namespace std;
//const int inf=0x7fffffff; //写成2^31-1不能做加运算,否则会溢出得到错误答案 
const int inf=9999999;
int e[1010][1010],dis[1010];
bool vis[1010];	
int n,m,k,ds;
void Dijkstra(int index){
	fill(dis,dis+1010,inf);
	fill(vis,vis+1010,false);
	dis[index]=0;
	for(int i=1;i<=n+m;i++){   
		int u=-1,min=inf;
		for(int j=1;j<=m+n;j++){
			if(vis[j]==false && dis[j]<min){
				u=j;
				min=dis[j];
			}
		}
		if(u==-1) break;
		vis[u]=true;
		for(int v=1;v<=m+n;v++){
			if(vis[v]==false && dis[v]>dis[u]+e[u][v]){
				dis[v]=dis[u]+e[u][v];
			}
		}
	}
}

int main(){
	cin>>n>>m>>k>>ds;
	fill(e[0],e[0]+1010*1010,inf);//初始化为不连通 
	fill(dis,dis+1010,inf);
	for(int i=1;i<=k;i++){
		string s,t;
		int a,b,tempdis;
		cin>>s>>t>>tempdis;
		if(s[0]=='G') 
		a=n+stoi(s.substr(1));//编号从 n 开始 ,这个操作很骚
		else a=stoi(s);
		if(t[0]=='G')
			b=n+stoi(t.substr(1)); 
		else b=stoi(t);
		if(e[a][b]==inf)  e[a][b]=e[b][a]=tempdis;
		else 
		    e[a][b]=e[b][a]=min(e[a][b],tempdis);//两点之间可能不止一条路,应该存短的那条,这个坑貌似没出过
	}
	int ansid=-1;
	int ansdis=-1,ansaver=inf;//ansdis尽可能大 
	//每一个加油站index跑 Dijkstra 
	for(int index=n+1;index<=n+m;index++){
		int mindis=inf,tempaver=0.0; 
		Dijkstra(index);
		int flag=true;     //标记是否存在不在服务范围的house 
		for(int i=1;i<=n;i++){
			if(dis[i]>ds){
				flag=false;
				break;
			}else tempaver+=dis[i]; 
			if(dis[i]<mindis) mindis=dis[i];//当前index加油站离house的最近最近距离 
		}
		if(flag){
			if(mindis>ansdis){  
			    ansid=index;
			    ansdis=mindis;
			    ansaver=tempaver;
		    }else if(mindis==ansdis && tempaver<ansaver){
			    ansid=index;
			    ansaver=tempaver;
		    }
		 
	    }
	}
	if(ansid==-1)
        printf("No Solution");
    else
        printf("G%d\n%.1f %.1f",ansid-n,ansdis*1.0,(ansaver*1.0)/n);
    return 0;
}

End!

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
用c++解决pipeline system consists of N transfer station, some of which are connected by pipelines. For each of M pipelines the numbers of stations A[i] and B[i], which are connected by this pipeline, and its profitability C[i] are known. A profitability of a pipeline is an amount of dollars, which will be daily yielded in taxes by transferring the gas through this pipeline. Each two stations are connected by not more than one pipeline. The system was built by Soviet engineers, who knew exactly, that the gas was transferred from Ukrainian gas fields to Siberia and not the reverse. That is why the pipelines are unidirectional, i.e. each pipeline allows gas transfer from the station number A[i] to the station number B[i] only. More over, if it is possible to transfer the gas from the station X to the station Y (perhaps, through some intermediate stations), then the reverse transfer from Y to X is impossible. It is known that the gas arrives to the starting station number S and should be dispatched to the buyers on the final station number F. The President ordered the Government to find a route (i.e. a linear sequence of stations which are connected by pipelines) to transfer the gas from the starting to the final station. A profitability of this route should be maximal. A profitability of a route is a total profitability of its pipelines. Unfortunately, the President did not consider that some pipelines ceased to exist long ago, and, as a result, the gas transfer between the starting and the final stations may appear to be impossible... Input The first line contains the integer numbers N (2 ≤ N ≤ 500) and M (0 ≤ M ≤ 124750). Each of the next M lines contains the integer numbers A[i], B[i] (1 ≤ A[i], B[i] ≤ N) and C[i] (1 ≤ C[i] ≤ 10000) for the corresponding pipeline. The last line contains the integer numbers S and F (1 ≤ S, F ≤ N; S ≠ F). Output If the desired route exists, you should output its profitability. Otherwise you should output "No solution".
最新发布
05-28
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值