1153 Decode Registration Card of PAT (25 point(s))

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

题目大意:给出一组准考证号和对应分数,按下面方式查询输出:
1:type1~等级(A/B/T)查询输出,输出该等级下的所有考生和对应分数,分数不同分数降序排序,分数相同准考证升序排列。

2:type2~考场查询,输出该考场下的总人数和总得分。

3:type3~日期查询,输出该日期下的考场号和对应考场人数,人数优先排序

分析:模拟题,较麻烦,练耐心。

不论何种查询,都需要在准考证字符串中获取有效信息,这里用 str.substr(i,len)函数截取即可。

1)首先定义一个结构体Node类型存储一下原始数据,再定义一个vector<Node>ans用于保存输出

2)type1等级查询,枚举匹配考生,push进ans容器,排序即可

3)type2考场查询,枚举匹配考生,计数,求和即可

4)type3日期查询,开个undered_map<Node>m存储,然后push进ans容器,排序即可。

      for(auto it:m) ans.push_back( {it.first,it.second} );

 

完整代码:

#include<bits/stdc++.h>
using namespace std;
struct Node{
	string id;
	int sco;
};
bool cmp(Node a,Node b){
	if(a.sco!=b.sco ) return a.sco  >b.sco ;
	else return a.id <b.id ; 
}

int main(){
	int n,query,type;
	cin>>n>>query;
	vector<Node>node(n);
	for(int i=0;i<n;i++){
		cin>>node[i].id >>node[i].sco; 
	}
	for(int i=0;i<query;i++){
		string temp;
		cin>>type>>temp;
		printf("Case %d: %d %s\n",i+1,type,temp.c_str());
		vector<Node>ans;
		int cnt=0,sum=0;
		if(type==1){
			for(int j=0;j<n;j++){
				if(temp[0]==node[j].id[0])
					ans.push_back(node[j]);
			}		
		}else if(type==2){
			for(int j=0;j<n;j++){
				string str=node[j].id.substr(1,3);
				if(str==temp ){
					cnt++;
					sum+=node[j].sco ;
					
				}
			}
			if(cnt!=0){
				cout<<cnt<<" "<<sum<<endl;
				continue;
			} 
			else if(cnt==0) cout<<"NA\n";
		}
		else if(type==3){
			    unordered_map<string,int>m;
				for(int j=0;j<n;j++){
					string str=node[j].id.substr(4,6);
				    if(temp==str) m[node[j].id.substr(1,3)]++;
				}
				for(auto it:m) ans.push_back({it.first,it.second});
			}
			sort(ans.begin(),ans.end(),cmp);
			for(int k=0;k<ans.size();k++){
				printf("%s %d\n",ans[k].id.c_str(),ans[k].sco);
			}
			if(((type==1 || type==3) && ans.size()==0)) cout<<"NA\n";
		}
		return 0;
}	

That‘s all !

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值