POJ 1338题解

描述
Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, …
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n’th ugly number.
输入
Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.
输出
For each line, output the n’th ugly number .:Don’t deal with the line with n=0.
样例输入
1
2
9
0
样例输出
1
2
10
来源
New Zealand 1990 Division I,UVA 136

题目要求我们输入一个数字n,输出第n个丑数,丑数的要求是为其质数因子仅有2、3、5。
一开始的思路是用三重for语句进行枚举,把符合的数字放入答案ans数组之中去,但是显然这个方法花费太大了,后来我看到有一个思路非常巧妙,可以根据其大小顺序生成答案数组。代码如下:

#include<iostream>
#include<cmath>
using namespace std;
const int num=1510;
int ans[num];
void getans(){
	ans[1]=1;
	int amount_2=1;
	int amount_3=1;
	int amount_5=1;
	for(int i=2;i<num;i++){
		ans[i]=min(ans[amount_2]*2,min(ans[amount_3]*3,ans[amount_5]*5));
		if(ans[i]==ans[amount_2]*2)            //2参与了贡献,递增之
		amount_2++;
		if(ans[i]==ans[amount_3]*3) 
		amount_3++;
		if(ans[i]==ans[amount_5]*5) 
		amount_5++;
	}
} 
int main(){
	int n;
	getans();
	while(cin>>n){
		if(n==0)  return 0;    //输入结束,程序终止
		cout<<ans[n]<<endl;
	}
	return 0;
}

这里通过对三个质因数的个数递加来向前,并且确保每次都是当前最小的数值填入到ans这个数组中,例如6就是由于2和3的贡献,这样把2与3的数量都++,可以避免重复!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值