Reverse Polish notation is a notation where every operator follows all of its operands. For example, an expression (1+2)*(5+4) in the conventional Polish notation can be represented as 1 2 + 5 4 + * in the Reverse Polish notation. One of advantages of the Reverse Polish notation is that it is parenthesis-free.
Write a program which reads an expression in the Reverse Polish notation and prints the computational result.
An expression in the Reverse Polish notation is calculated using a stack. To evaluate the expression, the program should read symbols in order. If the symbol is an operand, the corresponding value should be pushed into the stack. On the other hand, if the symbols is an operator, the program should pop two elements from the stack, perform the corresponding operations, then push the result in to the stack. The program should repeat this operations.
Input
An expression is given in a line. Two consequtive symbols (operand or operator) are separated by a space character.
You can assume that +, - and * are given as the operator and an operand is a positive integer less than 106
Output
Print the computational result in a line.
Constraints
2 ≤ the number of operands in the expression ≤ 100
1 ≤ the number of operators in the expression ≤ 99
-1 × 109 ≤ values in the stack ≤ 109
Sample Input 1
1 2 +
Sample Output 1
3
Sample Input 2
1 2 + 3 4 - *
Sample Output 2
-3
基础题,考察栈的概念,值得一提的是需要注意在减法计算的时候要注意顺序,千万别弄错了,应该先弹出b,再弹出a
#include<iostream>
#include<cstring>
#include<cstdlib>
using namespace std;
int top,S[1000];
void push(int x){
S[++top] = x;
}
int pop(){
top--;
return S[top+1];
}
int main(){
int a,b;
top = 0;
char s[100];
while(cin>>s){
if(s[0]=='+'){
a = pop();
b =pop();
push(a+b);
}
else if(s[0]=='-'){
b = pop();
a = pop();
push(a-b);
}
else if(s[0]=='*'){
a = pop();
b = pop();
push(a*b);
}
else {
push(atoi(s));
}
}
cout<<pop()<<endl;
return 0;
}