P2881 [USACO07MAR]排名的牛Ranking the Cows

题目描述

Each of Farmer John’s N cows (1 ≤ N ≤ 1,000) produces milk at a different positive rate, and FJ would like to order his cows according to these rates from the fastest milk producer to the slowest.

FJ has already compared the milk output rate for M (1 ≤ M ≤ 10,000) pairs of cows. He wants to make a list of C additional pairs of cows such that, if he now compares those C pairs, he will definitely be able to deduce the correct ordering of all N cows. Please help him determine the minimum value of C for which such a list is possible.

FJ想按照奶牛产奶的能力给她们排序。现在已知有N头奶牛(1 ≤ N ≤ 1,000)。FJ通过比较,已经知道了M(1 ≤ M ≤ 10,000)对相对关系。每一对关系表示为“X Y”,意指X的产奶能力强于Y。现在FJ想要知道,他至少还要调查多少对关系才能完成整个排序。

输入输出格式

输入格式:

Line 1: Two space-separated integers: N and M

Lines 2…M+1: Two space-separated integers, respectively: X and Y. Both X and Y are in the range 1…N and describe a comparison where cow X was ranked higher than cow Y.

输出格式:

Line 1: A single integer that is the minimum value of C.

输入输出样例

输入样例#1:

5 5
2 1
1 5
2 3
1 4
3 4

输出样例#1:

3

说明

From the information in the 5 test results, Farmer John knows that since cow 2 > cow 1 > cow 5 and cow 2 > cow 3 > cow 4, cow 2 has the highest rank. However, he needs to know whether cow 1 > cow 3 to determine the cow with the second highest rank. Also, he will need one more question to determine the ordering between cow 4 and cow 5. After that, he will need to know if cow 5 > cow 3 if cow 1 has higher rank than cow 3. He will have to ask three questions in order to be sure he has the rankings: “Is cow 1 > cow 3? Is cow 4 > cow 5? Is cow 5 > cow 3?”

题目分析

本题是一个无向图 利用位运算可以进行求解,每个点构造一个长度为maxn的序列 当一个点对另一个点有关系的时候 将两者之间的数置为1 然后对两者进行或运算 最后再将总的可能减去这些即可!

#include<iostream>
#include<bitset>
using namespace std;
const int maxn = 1000+5;
bitset<maxn>p[maxn];
int main(){
	int n,m;
	cin>>n>>m;
	for(int i = 1;i<=n;i++){
		p[i][i] = 1;  //对自己总是1
		
	}
	while(m--){
		int u,v;
		cin>>u>>v;
		p[u][v] = 1;
	}
	for(int k=1;k<=n;k++){
		for(int i=1;i<=n;i++){
			if(p[i][k]){
				p[i]|=p[k];  //或运算 
			}
		}
	}
	int ans = 0;
	for(int i=1;i<=n;i++){
		ans+=p[i].count();//第i个点中为1的点的个数
	}
	cout<<n*(n-1)/2-ans+n<<endl; //无向图 且将自己进行了重复计算 
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值