程序设计与算法(三)第2周测验(2019夏季)

1

编程填空:学生信息处理程序

输入
输入数据为一行,包括:
姓名,年龄,学号,第一学年平均成绩,第二学年平均成绩,第三学年平均成绩,第四学年平均成绩。
其中姓名为由字母和空格组成的字符串(输入保证姓名不超过20个字符,并且空格不会出现在字符串两端),年龄、学号和学年平均成绩均为非负整数。信息之间用逗号隔开。
输出
输出一行数据,包括:
姓名,年龄,学号,四年平均成绩。
信息之间用逗号隔开。
样例输入
Tom Hanks,18,7817,80,80,90,70
样例输出
Tom Hanks,18,7817,80
提示
必须用类实现,其中所有成员变量都是私有的。
输出结果中,四年平均成绩不一定为整数。

#include <iostream>
#include <string>
#include <cstdio>
#include <cstring>
#include <sstream>
#include <cstdlib>
using namespace std;

class Student {
// 在此处补充你的代码
private:
    static const int number = 4;
	char name[20];
	int age;
	int id;
	int score[number];
public:
	double calculate(){
		double sum = 0;
		for(int i=0;i<number;i++){
			sum += score[i];
			
		}
		
		
		return sum/number;
	}
	void input(){
		char buf[210];
		cin.getline(buf,200);
		char *p = strtok(buf,",");
		strcpy(name,p);
		p = strtok(NULL,",");
		age = atoi(p);
		p = strtok(NULL,",");
		id = atoi(p);
		for(int i=0;i<number;i++){
			p = strtok(NULL,",");
			score[i] = atoi(p);
		}
	}
	
	void output(){
		cout<<name<<","<<age<<","<<id<<","<<calculate()<<endl;
	}
};

int main() {
	Student student;        // 定义类的对象
	student.input();        // 输入数据
	student.calculate();    // 计算平均成绩
	student.output();       // 输出数据
}

2

奇怪的类复制

输入

输出
9
22
5
样例输入
None
样例输出
9
22
5

#include <iostream>
using namespace std;
class Sample {
public:
	int v;
// 在此处补充你的代码
	Sample(){
		
	}
	Sample(int n){
		v = n;
	}
	Sample(const Sample &a){
		v = a.v+2;
	}
};
void PrintAndDouble(Sample o)
{
	cout << o.v;
	cout << endl;
}
int main()
{
	Sample a(5);
	Sample b = a;
	PrintAndDouble(b);
	Sample c = 20;
	PrintAndDouble(c);
	Sample d;
	d = a;
	cout << d.v;
	return 0;
}

3

超简单的复数类

输入

输出
3+4i
5+6i
样例输入

样例输出
3+4i
5+6i

#include <iostream>
#include <cstring>
#include <cstdlib>
using namespace std;
class Complex {
private:
    double r,i;
public:
    void Print() {
        cout << r << "+" << i << "i" << endl;
    }
// 在此处补充你的代码
	Complex(){
	}
	Complex(const char*p){
		r = p[0]-'0';
		i = p[2]-'0';
	}
};
int main() {
    Complex a;
    a = "3+4i"; a.Print();
    a = "5+6i"; a.Print();
    return 0;
}

4

哪来的输出

输入

输出
2
1
样例输入

样例输出
2
1

#include <iostream>
using namespace std;
class A {
	public:
		int i;
		A(int x) { i = x; }
// 在此处补充你的代码
	~A(){
		cout<<i<<endl;
	}
};
int main()
{
	A a(1);
	A * pa = new A(2);
	delete pa;
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值