1103 Integer Factorization (30分) dfs 基础题

1103 Integer Factorization (30分)

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

 

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

 

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

 

Sample Input 2:

169 167 3

 

Sample Output 2:

Impossible

 

#include<iostream>
#include<vector>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
vector<int> ans,temp,fac;
int n,k,p,max_fac_sum=-1;
void init(int k,int p){
	int i=1;
	ans.clear();
	temp.clear();
	fac.clear();
	for(i=0;i<=20;i++){
		fac.push_back(pow(i,p));
	}
}
int dfs(int index,int cur_k,int sum,int fac_sum){
	 if(cur_k==k&&sum==n){
     	if(fac_sum>max_fac_sum)
     	{
     		ans=temp;
     		max_fac_sum=fac_sum;
//     		for(int i=1;i<ans.size();i++)
//     		{
//     			cout<<ans[i]<<" ";
//			}
//			cout<<endl;
		}
		return 0;
	 }
 	if(sum>n||cur_k>k)
 	return 0; 
	if(index>0){
		
		temp.push_back(index);
		dfs(index,cur_k+1,sum+fac[index],fac_sum+index);
		temp.pop_back();
		dfs(index-1,cur_k,sum,fac_sum);
	}
	return 0;
}
int main(){
	scanf("%d %d %d",&n,&k,&p);
	init(k,p);
	
	dfs(fac.size()-1,0,0,0);
	if(max_fac_sum==-1){
		printf("Impossible\n");
	}
	else{
		for(int i=0;i<ans.size();i++){
			if(i==0){
				printf("%d = %d^%d",n,ans[i],p);
			}
			else{
				printf(" + %d^%d",ans[i],p);
			}
		}
		printf("\n");
	}   
	return 0;
} 

题意:

给三个数,npk,把n因式分解,分解成p个数的k次方之和。

要求:

     这p个数之和最大,如果存在多种情况,则输出字典序最大的那个。(可以重复选)

难点解析:

字典序:从大到小选择。

求最大和:

if(cur_k==k&&sum==n){
     	if(fac_sum>max_fac_sum)
     	{
     		ans=temp;
     		max_fac_sum=fac_sum;

寒假第一天

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值