PAT乙级1042 字符统计 (Cpp)

1042 字符统计 (20 分)

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

输出样例:

e 7

代码如下:

#include <iostream>
#include <cstring>
#include <string>
using namespace std;
const int MAX = 1009;
bool isAlpha(char c) {
	if (c == ' ') return false;
	else if (c >= 'A' && c <= 'Z') return true;
	else if (c >= 'a' && c <= 'z') return true;
	else return false;
}
int main() {
	char str[MAX];
	int max = 0, p = 0;
	cin.getline(str, 1009);
	int len = strlen(str);
	int asc;
	int temp[MAX] = {0};
	for (int i = 0; i < len; i++) {
		if (isAlpha(str[i])) {
			if (str[i] >= 'A' && str[i] <= 'Z') str[i] = str[i] - 'A' + 'a';
			asc = str[i];
			temp[asc]++;
			if (temp[asc] > max) {max = temp[asc];p = asc;}
		}
	} 
	for (int i = 97; i < 123; i++) 
		if (temp[i] == max) {p = i; break;}
	printf("%c %d", p, temp[p]);
	return 0; 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值