SDUT ACM 顺序表应用1:多余元素删除之移位算法《基于C语言》

 

C顺序表应用1:多余元素删除之移位算法

Time Limit: 1000 ms Memory Limit: 650 KiB

Submit Statistic Discuss

Problem Description

一个长度不超过10000数据的顺序表,可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只保留第一个)。
要求:
       1、必须先定义线性表的结构与操作函数,在主函数中借助该定义与操作函数调用实现问题功能;
       2、本题的目标是熟悉顺序表的移位算法,因此题目必须要用元素的移位实现删除;

Input

 第一行输入整数n,代表下面有n行输入;
之后输入n行,每行先输入整数m,之后输入m个数据,代表对应顺序表的每个元素。

Output

 输出有n行,为每个顺序表删除多余元素后的结果

Sample Input

4
5 6 9 6 8 9
3 5 5 5
5 9 8 7 6 5
10 1 2 3 4 5 5 4 2 1 3

Sample Output

6 9 8
5
9 8 7 6 5
1 2 3 4 5

Hint

 

Source

 

#include <stdio.h>
#include <stdlib.h>
struct st
{
    int data;
    struct st *next;
};
int main()
{
    int n,i,k,m;
    struct st *head,*p,*d,*q,*tail;
    scanf("%d",&n);
    for(k=0; k<n; k++)
    {
        scanf("%d",&m);
        head=(struct st*)malloc(sizeof(struct st));
        head->next=NULL;
        tail=head;
        for(i=0; i<m; i++)
        {
            p=(struct st*)malloc(sizeof(struct st));
            scanf("%d",&p->data);
            p->next=NULL;
            tail->next=p;
            tail=p;
        }
        d=head->next;
        while(d!=NULL)
        {
            p=d;
            q=p->next;
            while(q!=NULL)
            {
                if(d->data==q->data)
                {
                    p->next=q->next;
                    q=q->next;
                }
                else
                {
                    p=q;
                    q=q->next;
                }
            }
            d=d->next;
        }
        p=head->next;
        while(p!=NULL)
        {
            printf("%d ",p->data);
            p=p->next;
        }
        printf("\n");
    }



    return 0;
}

 C++

#include <iostream>
#include<string.h>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
typedef struct st
{
    struct st *next;
    int data;
} tree;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        tree *head,*p,*tail,*q,*d;
        head=new tree;
        head->next=NULL;
        tail=head;
        for(int i=0; i<n; i++)
        {
            p=new tree;
            cin>>p->data;
            p->next=NULL;
            tail->next=p;
            tail=p;
        }
        d=head->next;
        while(d)
        {
            p=d;
            q=p->next;
            while(q)
            {
                if(q->data==d->data)
                {
                    p->next=q->next;
                    q=q->next;
                }
                else
                {
                    p=q;
                    q=q->next;
                }
            }
            d=d->next;
        }
        p=head->next;
        while(p)
        {
            if(p->next==NULL)printf("%d\n",p->data);
            else printf("%d ",p->data);
            p=p->next;
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值