进制转换
Time Limit: 1000 ms
Memory Limit: 65536 KiB
Problem Description
输入一个十进制数N,将它转换成R进制数输出。
Input
输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R != 10)。
Output
为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。
Sample Input
7 2 23 12 -4 3
Sample Output
111 1B -11
Hint
Source
HDOJ
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
char s[200];
int n,m,j,r;
while(scanf("%d%d",&n,&r)!=EOF)
{
int i=-1;
if(n==0)
{
printf("0\n");
}
if(n<0)
{
printf("-");
n=-n;
}
while(n)
{
m=n%r;
if(m<=9)
{
s[++i]='0'+m;
}
else
{
s[++i]=m-10+'A';
}
n=n/r;
}
for(j=i; j>=0; j--)
{
if(j==0)printf("%c\n",s[j]);
else printf("%c",s[j]);
}
}
return 0;
}