SDUT OJ 算术表达式的转换

算术表达式的转换

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

小明在学习了数据结构之后,突然想起了以前没有解决的算术表达式转化成后缀式的问题,今天他想解决一下。

   因为有了数据结构的基础小明很快就解出了这个问题,但是他突然想到怎么求出算术表达式的前缀式和中缀式呢?小明很困惑。聪明的你帮他解决吧。

Input

 输入一算术表达式,以\'#\'字符作为结束标志。(数据保证无空格,只有一组输入)

Output

 输出该表达式转换所得到的前缀式 中缀式 后缀式。分三行输出,顺序是前缀式 中缀式 后缀式。

Sample Input

a*b+(c-d/e)*f#

Sample Output

+*ab*-c/def
a*b+c-d/e*f
ab*cde/-f*+

Hint

 

Source

我的建议就是,先把简单的中缀和后缀写出来,运行看对了,在写前缀,前缀也就和后缀相反,不过有点不同,自己看代码理解吧,,加油!

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
int st(char a)
{
    if(a=='-'||a=='+')return 1;
    else if(a=='/'||a=='*')return 2;
    else if(a==')')return 3;
    else if(a=='(')return 4;
    return 0;
}
void qan(char s[])
{
    char a[10101],b[10101],c[10101];
    int n;
    int i;
    int p=0;
    int pp=0;
    int k=0;
    n=strlen(s);
    for(i=n-2; i>=0; i--)
    {
        a[k++]=s[i];
    }
    a[k]='#';
    for(i=0; a[i]!='#'; i++)
    {
        if(a[i]>='a'&&a[i]<='z')
        {
            p++;
            b[p]=a[i];
        }
        else
        {
            if(a[i]==')')
            {
                pp++;
                c[pp]=a[i];
            }
            else if(a[i]=='(')
            {
                while(c[pp]!=')')
                {
                    p++;
                    b[p]=c[pp];
                    pp--;
                }
                pp--;
            }
            else
            {
                if(st(a[i])<st(c[pp]))
                {
                    if(c[pp]==')')
                    {
                        pp++;
                        c[pp]=a[i];
                    }
                    else
                    {
                        p++;
                        b[p]=c[pp];
                        c[pp]=a[i];
                    }

                }
                else
                {
                    pp++;
                    c[pp]=a[i];
                }
            }
        }

    }
    while(pp)
    {
        p++;
        b[p]=c[pp];
        pp--;
    }
    for(i=p; i>=1; i--)
    {
        printf("%c",b[i]);
    }
    printf("\n");
}
void zh(char s[])
{
    int i;
    for(i=0; s[i]!='#'; i++)
    {
        if(s[i]!='('&&s[i]!=')')
        {
            printf("%c",s[i]);
        }
    }
    printf("\n");
}
void hou(char s[])
{
    int top=0;
    char b[10010];
    int i;
    for(i=0; s[i]!='#'; i++)
    {
        if(s[i]>='a'&&s[i]<='z')
            printf("%c",s[i]);
        else
        {
            if(top==0)
            {
                top++;
                b[top]=s[i];
            }
            else if(st(s[i])>st(b[top]))
            {
                if(s[i]==')')
                {
                    while(b[top]!='(')
                    {
                        printf("%c",b[top]);
                        top--;
                    }
                    top--;
                }
                else
                {
                    top++;
                    b[top]=s[i];
                }
            }
            else
            {
                if(b[top]=='(')
                {
                    top++;
                    b[top]=s[i];
                }
                else
                {
                    printf("%c",b[top]);
                    b[top]=s[i];
                }
            }

        }
    }
    while(top)
    {
        printf("%c",b[top]);
        top--;
    }
    printf("\n");
}
int main()
{
    char s[10101];
    while(scanf("%s",s)!=EOF)
    {
        qan(s);
        zh(s);
        hou(s);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值