SDUT OJ Period

Period

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

For each prefix of a given string S with N characters (each character has an

ASCII code between 97 and 126, inclusive), we want to know whether the prefix

is a periodic string. That is, for each i (2 ≤ i ≤ N) we want to know the largest K

> 1 (if there is one) such that the prefix of S with length i can be written as AK ,

that is A concatenated K times, for some string A. Of course, we also want to

know the period K.

 

Input

 The input file consists of several test cases. Each test case consists of two

lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.

The second line contains the string S. The input file ends with a line, having the

number zero on it.

 

Output

 For each test case, output “Test case #” and the consecutive test case

number on a single line; then, for each prefix with length i that has a period K >

1, output the prefix size i and the period K separated by a single space; the

prefix sizes must be in increasing order. Print a blank line after each test case.

 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4

Hint

题目的意思是说,给一个n长度的字符串给你,然后让你找出i>=2的前缀同时求出他的周期k

#include<string.h>
#include<stdio.h>
#define N 1000010
char s[N];
int next[N];
void st(char s[])//判断字符串中关系
{
    int i=0;
    int j=-1;
    int len=strlen(s);
    next[0]=-1;
    while(i<=len)
    {
        if(j==-1||s[i]==s[j])
        {
            j++;
            i++;
            next[i]=j;
        }
        else j=next[j];
    }
}
int main()
{
    int n,i;
    int j=0;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)break;
        scanf("%s",s);
        st(s);
        j++;
        printf("Test case #%d\n",j);
        for(i=2; i<=n; i++)
        {
            if(i%(i-next[i])==0&&i!=(i-next[i]))
            {
                printf("%d %d\n",i,i/(i-next[i]));//i为前缀,i/(i-next[i])为其周期
            }
        }
        printf("\n");
    }

    return 0;
}

 

SDUT-OJ(Software Development University of Tsinghua Online Judge)是一个在线编程平台,提供给清华大学软件学院的学生和爱好者练习和解决算法问题的环境,其中包括各种计算机科学题目,包括数据结构、算法、图形等。对于"最小生成树"(Minimum Spanning Tree, MST)问题,它是图论中的经典问题,目标是从一个加权无向图中找到一棵包含所有顶点的树,使得树的所有边的权重之和最小。 在C语言中,最常见的是使用Prim算法或Kruskal算法来求解最小生成树。Prim算法从一个顶点开始,逐步添加与当前生成树相连且权重最小的边,直到所有顶点都被包含;而Kruskal算法则是从小到大对所有边排序,每次选取没有形成环的新边加入到树中。 如果你想了解如何用C语言实现这些算法,这里简单概括一下: - 通常使用优先队列(堆)来存储边和它们的权重,以便快速查找最小值。 - 从任意一个顶点开始,遍历与其相邻的边,若新边不形成环,就更新树,并将新边加入优先队列。 - Kruskal算法: - 先将所有的边按照权重升序排序。 - 创建一个空的最小生成树,然后依次取出排序后的边,如果这条边连接的两个顶点不在同一个连通分量,则将其添加到树中。 如果你需要更详细的代码示例,或者有具体的问题想了解(比如如何处理环、如何实现优先队列等),请告诉我,我会为你提供相应的帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值