SDUT OJ 数据结构实验之求二叉树后序遍历和层次遍历

数据结构实验之求二叉树后序遍历和层次遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

 已知一棵二叉树的前序遍历和中序遍历,求二叉树的后序遍历和层序遍历。

Input

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的先序遍历序列,第二个字符串表示二叉树的中序遍历序列。

Output

每组第一行输出二叉树的后序遍历序列,第二行输出二叉树的层次遍历序列。

Sample Input

2
abdegcf
dbgeafc
xnliu
lnixu

Sample Output

dgebfca
abcdefg
linux
xnuli

Hint

Source

ma6174

#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
typedef struct st
{
    struct st *l,*r;
    char data;
} tree;
tree *creat(char *tr1,char *tr2,int len)
{
    tree *p;
    if(len<=0)p=NULL;
    else
    {
        p=new tree;
        p->data=*tr1;
        char *a;
        for(a=tr2; a!=NULL; a++)
            if(*a==*tr1)break;
        int lm=a-tr2;
        p->l=creat(tr1+1,tr2,lm);
        p->r=creat(tr1+1+lm,a+1,len-1-lm);

    }
    return p;
}
void hou(tree *t)
{
    if(t)
    {
        hou(t->l);
        hou(t->r);
        cout<<t->data;
    }
}
void cen(tree *t)
{
    tree *p[1010];
    int flas=0;
    int glas=0;
    if(t)
        p[flas++]=t;
    while(flas>glas)
    {
        t=p[glas++];
        cout<<t->data;
        if(t->l)
        {
            p[flas++]=t->l;

        }
        if(t->r)
        {
            p[flas++]=t->r;
        }
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        tree *T;
        char tr1[51];
        char tr2[51];
        cin>>tr1;
        cin>>tr2;
        int len=strlen(tr1);
        T=creat(tr1,tr2,len);
        hou(T);
        cout<<endl;
        cen(T);
        cout<<endl;
    }

    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值