数据结构实验之链表九:双向链表
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
学会了单向链表,我们又多了一种解决问题的能力,单链表利用一个指针就能在内存中找到下一个位置,这是一个不会轻易断裂的链。但单链表有一个弱点——不能回指。比如在链表中有两个节点A,B,他们的关系是B是A的后继,A指向了B,便能轻易经A找到B,但从B却不能找到A。一个简单的想法便能轻易解决这个问题——建立双向链表。在双向链表中,A有一个指针指向了节点B,同时,B又有一个指向A的指针。这样不仅能从链表头节点的位置遍历整个链表所有节点,也能从链表尾节点开始遍历所有节点。对于给定的一列数据,按照给定的顺序建立双向链表,按照关键字找到相应节点,输出此节点的前驱节点关键字及后继节点关键字。
Input
第一行两个正整数n(代表节点个数),m(代表要找的关键字的个数)。第二行是n个数(n个数没有重复),利用这n个数建立双向链表。接下来有m个关键字,每个占一行。
Output
对给定的每个关键字,输出此关键字前驱节点关键字和后继节点关键字。如果给定的关键字没有前驱或者后继,则不输出。
注意:每个给定关键字的输出占一行。
一行输出的数据之间有一个空格,行首、行末无空格。
Sample Input
10 3
1 2 3 4 5 6 7 8 9 0
3
5
0
Sample Output
2 4
4 6
9
Hint
Source
#include <iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
typedef struct st
{
struct st *next,*front;
int data;
} tree;
int main()
{
tree *head,*tail,*p;
head=new tree;
head->next=NULL;
head->front=NULL;
tail=head;
int n,m;
cin>>n>>m;
for(int i=0; i<n; i++)
{
p=new tree;
cin>>p->data;
p->next=tail->next;
p->front=tail;
tail->next=p;
tail=p;
}
while(m--)
{
int x;
cin>>x;
for(p=head->next; p; p=p->next)
{
if(x==p->data)
break;
}
if(p->front!=head&&p->next!=NULL)
printf("%d %d\n",p->front->data,p->next->data);
if(p->front==head&&p->next!=NULL)
printf("%d\n",p->next->data);
if(p->front!=head&&p->next==NULL)
printf("%d\n",p->front->data);
}
return 0;
}