SDUt OJ数据结构实验之栈与队列二:一般算术表达式转换成后缀式

数据结构实验之栈与队列二:一般算术表达式转换成后缀式

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。

Input

输入一个算术表达式,以‘#’字符作为结束标志。

Output

输出该表达式转换所得到的后缀式。

Sample Input

a*b+(c-d/e)*f#

Sample Output

ab*cde/-f*+

Hint

Source

#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int st(char a)
{
    if(a=='-'||a=='+')return 1;
    else if(a=='*'||a=='/')return 2;
    else if(a=='(')return 3;
    else if(a==')')return 4;
    return 0;
}
int main()
{
    string s;
    string b;
    int top=0;
    int i;
    cin>>s;
    for(i=0; s[i]!='#'; i++)
    {
        if(s[i]>='a'&&s[i]<='z')
            cout<<s[i];
        else
        {
            if(top==0)
            {
                top++;
                b[top]=s[i];
            }
            else if(st(s[i])>st(b[top]))
            {
                if(st(s[i])==4)
                {
                    while(b[top]!='(')
                    {
                        cout<<b[top];
                        top--;
                    }
                    top--;
                }
                else
                {
                    top++;
                    b[top]=s[i];
                }
            }
            else
            {
                if(b[top]=='(')
                {
                    top++;
                    b[top]=s[i];
                }
                else
                {
                    cout<<b[top];
                    b[top]=s[i];
                }
            }
        }
    }
    while(top)
    {
        cout<<b[top];
        top--;
    }
    cout<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值